HDU--ACMSteps--Who's in the Middle

Title:Who’s in the Middle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1…1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

  • Line 1: A single integer N
  • Lines 2…N+1: Each line contains a single integer that is the milk output of one cow.

Output

  • Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3

题目分析:
1、数据的存储:用一维数组存储N头奶牛的产奶量;
2、数据的处理:用sort函数进行排序即可;
3、数据的输出:排序后的数组输出其中间数据。
代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
int a[10000];
int main()
{
	int n;
	int i=0;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		cin>>a[i];
	    
	    sort(a,a+i);
	    int mid=(i-1)/2;
	    cout<<a[mid]<<endl;
    }
    return 0;
 } 

期待读者探讨:
题目中未说明有多组测试用例,但是依然要用while(scanf("%d",&n)!=EOF)这条语句来实现文件的多组数据读入,这是为什么呢?
比如代码这样会报错:

#include<iostream>
#include<algorithm>
using namespace std;
int a[10000];
int main()
{
	int n;
	cin>>n;
	int i=0;
	while(n--)
	{
		cin>>a[i];
		i++;
    }
    sort(a,a+i);
	int mid=(i-1)/2;
	cout<<a[mid]<<endl;
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值