计量大学 I Isolated Pointset

I Isolated Pointset

On a two-dimensional plane, YHH has a series of isolated points named PointSet, which contains N points in it. YHH would like to know if there is a way to draw a vertical bisector from any two points in the PointSet, passing through at least one point in the PointSet. Please help him.

Input Specification:

There are multiple test cases. The first line contains an integer T (1 ≤ T ≤ 2 × 10
​5
​​ ), indicating the number of test cases. For each test case:

Then followed T lines, each line contains an integer N (1 ≤ N ≤ 2 × 10
​5
​​ ), indicating the number of points in the PointSet.

Output Specification:

If there is a way to solve this problem, output “Yes”(without quotes), otherwise, output “No”(without quotes) instead.

Sample Input:

2
4
5

Sample Output:

Yes
Yes

题意

判断n个顶点构成的图案,他们任意两点的中垂线是否能够经过其他点(同集合内)。

简析

结论题,只有 n < = 2 n<=2 n<=2是非法态,否则一直构造等边三角形就能构成合法态。

参考代码

#include <bits/stdc++.h>
using namespace std;
const int N = 1000;
int c[N];

int solve(int &n) {
	if (n <= 2) return false;
	return true;
}

int main() {
	// freopen("in.txt", "r", stdin);
	int t;
	cin >> t;
	while (t--) {
		int n;
		cin >> n;
		puts(solve(n) ? "Yes" : "No");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值