Overflow(UVA - 465)

最近新学了一个函数的用法,头文件是 stdlib.h atof() 的函数,它可以把字符串的数字转化为double类型。

题目:

Write a program that reads an expression consisting of two non-negative integer and an operator.Determine if either integer or the result of the expression is too large to be represented as a “normal”signed integer (typeintegerif you are working Pascal, typeintif you are working in C).
Input
An unspecified number of lines. Each line will contain an integer, one of the two operators ‘+’ or ‘*’,and another integer.
Output
For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ‘first number too big’, ‘second number too big’, ‘result too big’.Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big

解题思路:就是先判断两个数是否超出范围,然后再判断加和乘结果是否超出范围。
1、atof()函数写法:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
long long max=2147483647;
int main()
{
	char s[5000],s1[5000],t;
	double u,v;
	while(scanf("%s %c %s",s,&t,s1)!=EOF)
	{
		printf("%s %c %s\n",s,t,s1);
		u=atof(s);
		v=atof(s1);
		if(u>max)
			printf("first number too big\n");
		if(v>max)
			printf("second number too big\n");
		if(t=='+'&&u+v>max)
			printf("result too big\n");
		else if(t=='*'&&u*v>max)
			printf("result too big\n");		
	}
	return 0;
}

2、不用atof()函数的代码:

#include<stdio.h>
#include<string.h>
long long max=2147483647;
int main()
{
	char s[5000],s1[5000],t;
	int n,m,i,j,k;
	long long u,v;
	while(scanf("%s %c %s",s,&t,s1)!=EOF)
	{
		printf("%s %c %s\n",s,t,s1);
		n=strlen(s);
		m=strlen(s1);
		u=v=0;
		for(i=0;i<n;i++)
		{
			u=u*10+s[i]-'0';
			if(u>max)
			{
				printf("first number too big\n");
				break;
			}
		} 
		for(i=0;i<m;i++)
		{
			v=v*10+s1[i]-'0';
			if(v>max)
			{
				printf("second number too big\n");
				break;
			}
		}
		if(t=='+'&&u+v>max)
			printf("result too big\n");
		else if(t=='*'&&u*v>max)
			printf("result too big\n");		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值