PAT甲级1070(月饼)

1070 Mooncake (25 point(s))

题目原文

  Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
  Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:
  Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:
  For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

题目大意

  月饼是中秋节的中国传统美食。不同地方的文化风俗不同,月饼里面的馅也不尽相同。现在给出所有种类月饼的库存量和总价值,以及市场的最大需求量,你需要求出能获得的最大利润

解题思路

  定义一个结构体,存储每种月饼的库存量,总价值和单价,然后依照单价从高到低排序,每次出售单价最高的月饼即可获得最大利润

代码

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <algorithm>
using namespace std;
//注意:读入double型数据,用%lf,而输出则用%f
const int maxn = 1005;

struct Mooncake {
	double storge, values, price;
} Mooncakes[maxn];

bool cmp(Mooncake a, Mooncake b) {
	return a.price > b.price;
}

int main()
{
	int N, D, i;
	int ret = scanf("%d %d", &N, &D);
	for (i = 0; i < N; ++i) {
		ret = scanf("%lf", &Mooncakes[i].storge);//输入每种月饼的库存量
	}
	for (i = 0; i < N; ++i) {
		ret = scanf("%lf", &Mooncakes[i].values);//输入每种月饼的总价
		Mooncakes[i].price = Mooncakes[i].values / Mooncakes[i].storge;
	}
	sort(Mooncakes, Mooncakes + N, cmp);
	double profit = 0;
	for (i = 0; i < N && D > 0; ++i) {
		if (D >= Mooncakes[i].storge) {
			profit += Mooncakes[i].values;
			D -= Mooncakes[i].storge;
		}
		else {
			profit += D * Mooncakes[i].price;
			D = 0;
		}
	}
	printf("%.2f", profit);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值