华为MSTP+VRRP(双机热备)

华为 专栏收录该内容
1 篇文章 0 订阅

华为MSTP+VRRP
【项目拓扑】
在这里插入图片描述

如图,PC1、PC2是企业内网的主机,分别属于VLAN10和VLAN20,LSW1和LSW2之间的g0/0/23口和g0/0/24口之间形成链路聚合。AR1是企业边界路由器,用于和外网通信。AR1、LSW1和LSW2之间运行RIP协议。LSW1、LSW2和LSW3之间运行MSTP协议。要让PC1、PC2出去和回来的流量方向一致,且形成第一跳网关冗余,且负载均衡。如下是配置。

本次实验用到的技术有:VLAN TRUNK RIP MSTP VRRP
【项目要求】
1、创建VLAN10、20 将相应的PC加入LSW3相应的接口,并把其与LSW1、2相连的接口设置为trunk链路
2、在LSW1和LSW2上分别添加VLAN 10 11 20与 VLAN 10 12 20,并将LSW1和LSW2 的GE0/0/1接口分别加入VLAN 11与VLAN 12并且给两个三层交换机的三个VLAN配置IP地址
3、首先配置LSW1和LSW2的链路聚合,然后在AR1、LSW1、LSW2上配置RIP配置协议使其通信
4、配置MSTP与VRRP完成网络规划

实施步骤:
1、配置路由器IP地址与RIP路由协议
AR 1根据图示配置IP地址

[AR1]interface GigabitEthernet0/0/0
[AR1-GigabitEthernet0/0/0]ip address 202.102.224.70 255.255.255.252

[AR1]interface GigabitEthernet0/0/1
[AR1-GigabitEthernet0/0/1]ip address 10.0.0.1 255.255.255.252

[AR1]interface GigabitEthernet0/0/2
[AR1-GigabitEthernet0/0/2]ip address 10.0.1.1 255.255.255.252

配置RIP协议
[AR1]rip 启动RIP协议
[AR1-rip-1] version 2 启动版本2
[AR1-rip-1]undo summary 关闭自动汇总
[AR1-rip-1]network 10.0.0.0 宣告直连网络
[AR1-rip-1]network 202.102.224.0

2、配置三层交换VLAN 、trunk、VLAN端口IP与链路聚合
LSW1
[LSW1]vlan batch 10 11 20 创建VLAN
[LSW1]int g 0/0/1
[LSW1-GigabitEthernet0/0/1]port link-type access 配置接口模式为access
[LSW1-GigabitEthernet0/0/1]port default vlan 11 将接口加入VLAN

[LSW1]int vlan 10
[LSW1-Vlanif10]ip add 192.168.0.2 24
[LSW1-Vlanif10]undo shutdown

[LSW1]int vlan 11
[LSW1-Vlanif11]ip add 10.0.0.2 30
[LSW1-Vlanif11]undo shutdown

[LSW1]int vlan 20
[LSW1-Vlanif20]ip add 192.168.1.3 24
[LSW1-Vlanif20]undo shutdown

LSW2
[LSW2]vlan batch 10 12 20
[LSW2]int g 0/0/1
[LSW2-GigabitEthernet0/0/1]port link-type access
[LSW2-GigabitEthernet0/0/1]port default vlan 12

[LSW2]int vlan 10
[LSW2-Vlanif10]ip add 192.168.0.3 24
[LSW2-Vlanif10]undo shutdown

[LSW2]int vlan 12
[LSW2-Vlanif12]ip add 10.0.1.2 30
[LSW2-Vlanif12]undo shutdown

[LSW2]int vlan 20
[LSW2-Vlanif20]ip add 192.168.1.2 24
[LSW2-Vlanif20]undo shutdown

进入接口
配置端口为trunk模式
允许VLAN10和VLAN10通过
[LSW1]int GigabitEthernet 0/0/2
[LSW1-GigabitEthernet0/0/2]port link-type trunk
[LSW1-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20

创建并进入链路聚合端口1配置
将g0/0/23和g0/0/24加入到eth-trunk1端口
配置端口为trunk模式
允许VLAN10和VLAN10通过
[LSW1]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]trunkport GigabitEthernet0/0/23
[LSW1-Eth-Trunk1]trunkport GigabitEthernet0/0/24
[LSW1-Eth-Trunk1]port link-type trunk
[LSW1-Eth-Trunk1]port trunk allow-pass vlan 10 20

[LSW2]int GigabitEthernet 0/0/2
[LSW2-GigabitEthernet0/0/2]port link-type trunk
[LSW2-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20

[LSW2]interface Eth-Trunk 1
[LSW2-Eth-Trunk1]trunkport GigabitEthernet0/0/23
[LSW2-Eth-Trunk1]trunkport GigabitEthernet0/0/24
[LSW2-Eth-Trunk1]port link-type trunk
[LSW2-Eth-Trunk1]port trunk allow-pass vlan 10 20

[LSW3]vlan batch 10 20
[LSW3]int GigabitEthernet 0/0/23
[LSW3-GigabitEthernet0/0/23]port link-type trunk
[LSW3-GigabitEthernet0/0/23]port trunk allow-pass vlan 10 20

[LSW3]int GigabitEthernet 0/0/24
[LSW3-GigabitEthernet0/0/24]port link-type trunk
[LSW3-GigabitEthernet0/0/24]port trunk allow-pass vlan 10 20

[LSW3]int g 0/0/1
[LSW3-GigabitEthernet0/0/1]port link-type access
[LSW3-GigabitEthernet0/0/1]port default vlan 10

[LSW3]int g 0/0/2
[LSW3-GigabitEthernet0/0/2]port link-type access
[LSW3-GigabitEthernet0/0/2]port default vlan 20

配置LSW1\LSW2的RIP路由
[LSW1]rip
[LSW1-rip-1]version 2
[LSW1-rip-1]un summary
[LSW1-rip-1]network 10.0.0.0
[LSW1-rip-1]net 192.168.0.0
[LSW1-rip-1]net 192.168.1.0

[LSW2]rip
[LSW2-rip-1]version 2
[LSW2-rip-1]un summary
[LSW2-rip-1]network 10.0.0.0
[LSW2-rip-1]network 192.168.0.0
[LSW2-rip-1]network 192.168.1.0

3、在交换机上配置VRRP协议,使LSW1成为vlan10的活跃路由器,LSW2成为vlan20的活跃路由器。
进入vlan10的逻辑端口
配置vrrp ID1 虚拟网关IP为192.168.0.1
配置当前设备在vrrp vrid 1 中的优先级为110(默认为100),使其成为 活跃路由器
LSW1
[LSW1]interface Vlanif 10
[LSW1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.0.1
[LSW1-Vlanif10]vrrp vrid 1 priority 110

进入vlan20的逻辑端口
配置vrrp ID2 虚拟网关IP为192.168.1.1
[LSW1]interface Vlanif 20
[LSW1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.1.1

进入vlan10的逻辑端口
配置vrrp ID1 虚拟网关IP为192.168.0.1
配置当前设备在vrrp vrid 1 中的优先级为110(默认为100),使其成为 活跃路由器
LSW2
[LSW2]interface Vlanif 10
[LSW2-Vlanif10]vrrp vrid 1 virtual-ip 192.168.0.1

进入vlan20的逻辑端口
配置vrrp ID2 虚拟网关IP为192.168.1.1
[LSW2]interface Vlanif 20
[LSW2-Vlanif20]vrrp vrid 2 virtual-ip 192.168.1.1
[LSW2-Vlanif20]vrrp vrid 2 priority 110

4、配置MSTP,实现LSW1成为vlan10根桥,LSW2成为vlan20的根桥
开启stp(华为设备默认开启stp)
配置stp类型为mstp(华为设备默认为mstp)
进入mst域配置模式
配置域名为b190(LSW1和LSW2以及LSW3的域名以及mstp实例与vlan的对应关系 配置需一致)
配置mstp实例1对应vlan10
配置mstp实例2对应vlan20
激活mst域配置(使以上配置生效)
使该设备成为mstp实例1的主根桥
使该设备成为mstp实例2的次根桥

[LSW1]stp enable
[LSW1]stp mode mstp
[LSW1]stp region-configuration
[LSW1-mst-region]region-name B190
[LSW1-mst-region]instance 1 vlan 10
[LSW1-mst-region]instance 2 vlan 20
[LSW1-mst-region]active region-configuration
[LSW1]stp instance 1 root primary
[LSW1]stp instance 2 root secondary

开启stp(华为设备默认开启stp)
配置stp类型为mstp(华为设备默认为mstp)
进入mst域配置模式
配置域名为b190(LSW1和LSW2以及LSW3的域名以及mstp实例与vlan的对应关系 配置需一致)
配置mstp实例1对应vlan10
配置mstp实例2对应vlan20
激活mst域配置(使以上配置生效)
使该设备成为mstp实例1的次根桥
使该设备成为mstp实例2的主根桥

[LSW2]stp enable
[LSW2]stp mode mstp
[LSW2]stp region-configuration
[LSW2-mst-region]region-name B190
[LSW2-mst-region]instance 1 vlan 10
[LSW2-mst-region]instance 2 vlan 20
[LSW2-mst-region]active region-configuration
[LSW2]stp instance 1 root secondary
[LSW2]stp instance 2 root primary

开启stp
配置stp类型为mstp
进入mst域配置模式
配置域名为b190
配置mstp实例1对应vlan10
配置mstp实例2对应vlan20
激活mst域配置

[LSW3]stp enable
[LSW3]stp mode mstp
[LSW3]stp region-configuration
[LSW3-mst-region]region-name B190
[LSW3-mst-region]instance 1 vlan 10
[LSW3-mst-region]instance 2 vlan 20
[LSW3-mst-region]active region-configuration

[LSA1]int vlan 10
[LSW1-Vlanif10]vrrp vrid 1 track interface vlanif 11 reduced 20
[LSW1-Vlanif10]vrrp vrid 1 preempt-mode timer delay 5

完成上述步骤即可完成实验

  • 12
    点赞
  • 0
    评论
  • 79
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值