n皇后问题(dfs-摆放问题)


你的任务是,对于给定的N,求出有多少种合法的放置方法。 

Input共有若干行,每行一个正整数N≤10,表示棋盘和皇后的数量;如果N=0,表示结束。Output共有若干行,每行一个正整数,表示对应输入行的皇后的不同放置数量。Sample Input

1
8
5
0

Sample Output

1
92
10

注意:
每一行必须摆放
a[t]=i 表示第t行,在第i列摆放皇后
预处理一下,否则超时
代码:
import java.util.Scanner;

public class Main{
//        static int n,cnt;
//        static int a[]=new int[15];
//        static boolean check(int t){
//                for(int i=0;i<t;i++)
//                        if(a[i]==a[t] || Math.abs(i-t)==Math.abs(a[i]-a[t]))
//                            return false;
//                return true;
//        }
//        static void dfs(int t){
//                if(t==n ) cnt++;
//                for(int i=0;i<n;i++){
//                        a[t]=i;
//                        if(check(t)) dfs(t+1);
//                }
//        }
//        public static void main(String[] args) {
//                Scanner scan=new Scanner(System.in);
//                while(scan.hasNext()){
//                        n=scan.nextInt();
//                        if(n==0) break;
//                        cnt=0;
//                        dfs(0);
//                        System.out.println(cnt);
//                }
//        }
    
    public static void main(String[] args) {
            Scanner scan=new Scanner(System.in);
            int a[]={1,0,0,2,10,4,40,92,352,724};
            while(scan.hasNext()){
                    int n=scan.nextInt();
                    if(n==0) break;
                    System.out.println(a[n-1]);
            }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值