排序:PAT Judge

很考验细节的题,刚开始一看发现非常简单,20分钟足矣,结果被疯狂打脸,沦落到吃泡面的地步

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10
​^4),the total number of users, K (≤5), the total number of problems, and M (≤10^​5), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

代码:

#include <cstdio>
#include <iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
	int id;
	int score[6];
	int sum;
	int rank;
	int subbmit;
}kkk[10000+5];
int mingci=1;
bool cmp(node p,node q){
	if(p.sum==q.sum){
		if(p.rank==q.rank){
			return p.id<q.id;
		}
		else return p.rank>q.rank;
	}
	else return p.sum>q.sum;
}
int main()
{	
	int maxscore[6],n,k,m,l,a,b;
	scanf("%d%d%d",&n,&k,&m);
	for(int i=1;i<=k;i++){
		scanf("%d",&maxscore[i]);
	}
	for(int i=1;i<=n;i++){
		kkk[i].id=0;
		kkk[i].sum=0;
		kkk[i].rank=0;
		kkk[i].subbmit=0;
		for(int j=0;j<6;j++) kkk[i].score[j]=-1;
	}//初始化 
	for(int i=0;i<m;i++){
		scanf("%d%d%d",&l,&a,&b);
		kkk[l].id=l;
		if(kkk[l].score[a]==-1)
			kkk[l].score[a]=0;
		if(b!=-1&&kkk[l].subbmit==0) 
			kkk[l].subbmit=1;
		if(b>=kkk[l].score[a]){
			kkk[l].score[a]=b;
		}
	}
	for(int i=1;i<=n;i++){
		for(int j=1;j<=k;j++){
			if(kkk[i].score[j]!=-1)
				kkk[i].sum+=kkk[i].score[j];
			if(kkk[i].score[j]==maxscore[j])
				kkk[i].rank++;
		}
	}
	sort(kkk+1,kkk+n+1,cmp);
	for(int i=1;i<=n;i++){
		if(kkk[i].subbmit==1) {
			printf("%d ",mingci);		
			if( kkk[i+1].sum != kkk[i].sum) mingci=i+1;
			printf("%05d %d",kkk[i].id,kkk[i].sum);
			for(int j=1;j<=k;j++){
				if(kkk[i].score[j]!=-1) printf(" %d",kkk[i].score[j]);
				else printf(" -");
			}
			printf("\n");
		}
	}
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值