HDU-1331-Function Run Fun(动态规划)

Function Run Fun

We all love recursion! Don’t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

思路:
按题目要求递归就行,用数组存一下。注意输出的格式(我第一次没注意就错了)。
代码实现:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[50][50][50];     //创建一个数组存

//按题目要求递归
int w(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
    {
        return 1;
    }
    else if(a>20||b>20||c>20)
    {
        return w(20,20,20);
    }
    else if(a<b&&b<c)
    {
        if(dp[a][b][c])
            return dp[a][b][c];
        else
            dp[a][b][c]=w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);
    }
    else
    {
        if(dp[a][b][c])
            return dp[a][b][c];
        else
            dp[a][b][c]=w(a-1,b,c)+w(a-1,b-1,c)+w(a-1,b,c-1)-w(a-1,b-1,c-1);

    }
    return dp[a][b][c];
}
int main()
{
    int a,b,c;
    while(~scanf("%d %d %d",&a,&b,&c))  //多组输入
    {
        memset(dp,0,sizeof(dp));    //清空数组
        if(a==-1&&b==-1&&c==-1)     //都为-1时跳出循环
        {
            break;
        }
        int x=w(a,b,c);             //调用递归函数
        //输出
        printf("w(%d, %d, %d) = %d\n",a,b,c,x); //注意输出格式有空格(刚开始没看到然后就错了)
    }
    return 0;
}

原题链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1331

这题不能直接用递归写。要不然会超时,而且超时不是一点点,是非常多。




超时代码:(直接无视就好,我只是想告诉大家,不能这样写)

//Time Limit Exceeded

/*#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;*/

#include<stdio.h>
int w(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
    {
        return 1;
    }
    else if(a>20||b>20||c>20)
    {
        return w(20,20,20);
    }
    else if(a<b&&b<c)
    {
        return w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);
    }
    else
    {
        return w(a-1,b,c)+w(a-1,b-1,c)+w(a-1,b,c-1)-w(a-1,b-1,c-1);
    }
}
int main()
{
    int a,b,c;
    while(~scanf("%d %d %d",&a,&b,&c))
    {
        if(a==-1&&b==-1&&c==-1)
        {
            break;
        }
        int x=w(a,b,c);
        printf("w(%d,%d,%d)=%d\n",a,b,c,x);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值