Can you solve this equation?(二分法)

Can you solve this equation?

Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input

2
100
-4

Sample Output

1.6152
No solution!

思路:
函数 f(x) 是单调递增的函数,所以用二分法(看不出来,求导一下就知道了)。题目说如果y在0到100之前就有解就打印解,超过范围就打印"No solution!"。
完整代码:

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
double y;

double q(double x)
{
    return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}

void binary_first(int x) //二分查找x第一次出现的位置
{
    double l=0.0,r=100.0;
    while(r-l>1e-6)             //计算机精度默认为1e-6
    {
        double bet=(l+r)/2;
        if(q(bet)>y) r=bet;
        else l=bet;
    }
    printf("%.4lf\n",r);
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>y;
        if(q(0)>y||q(100)<y)        //如果不在范围内
        {
            cout<<"No solution!"<<endl;
        }
        else
        {
            binary_first(y);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值