PAT甲级1092 To Buy or Not to Buy (20分) C++ / Java

该博客探讨了一个字符串子集匹配问题,即判断第二个字符串是否为第一个字符串的子集,并计算差异数量。提供了C++和Java两种语言的解决方案,利用哈希映射来快速检查和计算。博客中还提到了Java代码在PAT系统中可能存在的超时问题,可能与输入流有关。
摘要由CSDN通过智能技术生成

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

Figure 1

Input Specification:
Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:
For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

题目大意

比较第2串字符串是不是第1串字符串的子集。

  • 如果是 输出 Yes 和 2者之间的长度差
  • 如果不是 输出 No 和 第2串里多出的元素数目

C++

//Alg: Hash
#include<bits/stdc++.h>
using namespace std;
int main(){
	string a, b;
	cin >> a >> b;
	map<char, int> mp;
	for(char c : a) mp[c]++;
	for(char c : b) mp[c]--;
	int cnt = 0;
	for(auto x : mp)
		if(x.second < 0)//表示第2串里多了珠子 
			cnt += abs(x.second); 
	if(cnt > 0) cout<<"No"<<" "<<cnt;
	else  cout<<"Yes"<<" "<<abs( a.size() - b.size() );
	}

Java

//Hash
import java.util.*;
public class Main {
    public static void main(String[] args) {
    	//BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        Scanner cin = new Scanner(System.in);
        String a = cin.next(); 
        String b = cin.next();
        int[] mp = new int[128]; 
        for(char c : a.toCharArray()) mp[c]++;
        for(char c : b.toCharArray()) mp[c]--;
        int cnt = 0;
        for(int x : mp) 
        	if(x < 0)
        		cnt += -x;
        if(cnt > 0) System.out.println("No "+cnt);
        else System.out.println("Yes " + (a.length() - b.length()) ); 
    }
}

Java② 利用BufferedReader 玄学提速版

import java.util.*;
import java.io.*;
public class Main {
    public static void main(String[] args) throws IOException{
    	BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));//用BufferedReader替换Scanner流进行输入 
        //Scanner cin = new Scanner(System.in);
        String a = bf.readLine(); 
        String b = bf.readLine();
        int[] mp = new int[128]; 
        for(char c : a.toCharArray()) mp[c]++;
        for(char c : b.toCharArray()) mp[c]--;
        int cnt = 0;
        for(int x : mp) 
        	if(x < 0)
        		cnt += -x;
        if(cnt > 0) System.out.println("No "+cnt);
        else System.out.println("Yes " + (a.length() - b.length()) ); 
    }
}

后话:

PAT系统检查Java代码真的容易超时,很有可能是对Scanner输入流不兼容造成的
在这里插入图片描述
同样的算法,C++一次过

Java不仅不能调用Math.abs,而且全AC试了5、6次 = . =

数据治理是确保数据准确性、可靠性、安全性、可用性和完整性的体系和框架。它定义了组织内部如何使用、存储、保护和共享数据的规则和流程。数据治理的重要性随着数字化转型的加速而日益凸显,它能够提高决策效率、增强业务竞争力、降低风险,并促进业务创新。有效的数据治理体系可以确保数据在采集、存储、处理、共享和保护等环节的合规性和有效性。 数据质量管理是数据治理中的关键环节,它涉及数据质量评估、数据清洗、标准化和监控。高质量的数据能够提升业务决策的准确性,优化业务流程,并挖掘潜在的商业价值。随着大数据和人工智能技术的发展,数据质量管理在确保数据准确性和可靠性方面的作用愈发重要。企业需要建立完善的数据质量管理和校验机制,并通过数据清洗和标准化提高数据质量。 数据安全与隐私保护是数据治理中的另一个重要领域。随着数据量的快速增长和互联网技术的迅速发展,数据安全与隐私保护面临前所未有的挑战。企业需要加强数据安全与隐私保护的法律法规和技术手段,采用数据加密、脱敏和备份恢复等技术手段,以及加强培训和教育,提高安全意识和技能水平。 数据流程管理与监控是确保数据质量、提高数据利用率、保护数据安全的重要环节。有效的数据流程管理可以确保数据流程的合规性和高效性,而实时监控则有助于及时发现并解决潜在问题。企业需要设计合理的数据流程架构,制定详细的数据管理流程规范,并运用数据审计和可视化技术手段进行监控。 数据资产管理是将数据视为组织的重要资产,通过有效的管理和利用,为组织带来经济价值。数据资产管理涵盖数据的整个生命周期,包括数据的创建、存储、处理、共享、使用和保护。它面临的挑战包括数据量的快速增长、数据类型的多样化和数据更新的迅速性。组织需要建立完善的数据管理体系,提高数据处理和析能力,以应对这些挑战。同时,数据资产的类与评估、共享与使用规范也是数据资产管理的重要组成部,需要制定合理的标准和规范,确保数据共享的安全性和隐私保护,以及建立合理的利益配和权益保障机制。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值