Supermarket | 贪心 + 优先队列

Supermarket | 贪心 + 优先队列


from poj 1456
from acwing 145
时间限制 :2s
内存限制:65M

Description:

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10
Sample Output
80
185
Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.


题目大意:

一个超市有 一些即将过期商品,且每天只能卖出一件商品,给定你这些过期商品的利润和过期日期,问你这家超市能获得的最多收益是多少。

这个题目一看肯定第一时间就是想到贪心吧!?

这个题目可以将所有的商品按照过期时间排序,从最后一天开始遍历,对于每一天,只要有过期日期超过这一天的商品,那么就在所有过期日期在该天之后的商品中挑出利润最大的商品在该天出售。

AC代码:
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
#define pii pair<int,int>
pii w[10005];			//每件商品的利润和价格都用一个pair存储
bool cmp(pii a,pii b){
    return a.second > b.second;		//按照商品的过期时间从大到小排序
}
int n,max_day,note,sum;				//商品数,所有商品过期时间最晚的时间,记录某件商品,最大利益
priority_queue<int> q;				//存储目前能卖的商品
int main(){
    while(cin>>n){
        note = 1,sum = 0;
        for(int i = 1;i <= n;++i) cin>>w[i].first>>w[i].second;
        sort(w + 1,w + 1 + n,cmp);
        max_day = w[1].second;
        while(!q.empty()) q.pop();
        while(max_day--){				//从最后一天往前遍历
            while(note <= n && w[note].second > max_day)	//如果某件商品的过期日期大于max_day说明它在该天是能卖的,存入到优先队列
                q.push(w[note++].first);
            if(!q.empty())		//每一天都从优先队列中取出可卖的利润最大的商品售卖
                sum += q.top(),q.pop();
        }
        cout<<sum<<endl;
    }
    return 0;
}

其他方法:
纯贪心
贪心 + 并查集

use java language ,In this project you need to write a book lending system for a Library. The system has different roles for registered users. There are two types of user roles: borrower and lender. Write an IUser interface for library users, with the following UML specification: +----------------------------------+ | <<interface>> | | IUser | +----------------------------------+ | + getName(): String | | + getBook(): int | | + moreBook(int number): void | +----------------------------------+ and a User class that implements IUser and has the following UML specification: +-----------------------------------+ | User | +-----------------------------------+ | - name: String | | - book: int | +-----------------------------------+ | + User(String name, int book) | | + getName(): String | | + getBook(): int | | # setBook(int book): void | | + moreBook(int number): void | | + testUser(): void | +-----------------------------------+ The name instance variable indicates the user name. The book instance variable indicates the number of books borrowed by the user. The setBook method changes the number of books borrowed by the user. The setBook method is protected, not public. This means that only subclasses of the User class can use the setBook method. All the other classes in the system cannot use the setBook method, so they cannot change the number of books borrowed by a user. The purpose of the moreBook method is to increase the number of books borrowed or lent by the user (depending on what kind of user it is) by the number given as argument to the method. The moreBook method of the User class is abstract, since we do not know what kind of role the user is (a borrower borrows books from other users and a lender lend books to other users). Also add to your program a Test class to test your User class. public class Test { public static void main(String[] args) { User.testUser(); } }
最新发布
05-25
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Alan_Lowe

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值