1031 Hello World for U

该博客介绍了一种将任意字符串按照U形进行输出的方法。具体要求是保持字符的原始顺序,同时使得形成的U尽可能接近正方形。通过计算和判断字符串长度对3的余数,确定左右竖线和底部横线的字符数量,并存储在二维字符数组中,最后按U形输出。代码示例使用C++实现,实现了满足条件的字符串U形输出。
摘要由CSDN通过智能技术生成

1031 Hello World for U

0、题目

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

1、大致题意

用所给字符串按U型输出。n1和n3是左右两条竖线从上到下的字符个数,n2是底部横线从左到右的字符个数。并满足一下要求:

  1. n1 == n3
  2. n2 >= n1
  3. n1为在满足上述条件的情况下的最大值

2、基本思路

分三种情况讨论:

  1. 如果 n % 3 = = 0 n \% 3 == 0 n%3==0 ,直接 n 1 = n 2 = n 3 n1 = n2 = n3 n1=n2=n3
  2. 如果 n % 3 = = 1 n \% 3 == 1 n%3==1,因为 n 2 n2 n2 要比 n 1 n1 n1 大,所以把多出来的那1个给 n 2 n2 n2
  3. 如果 n % 3 = = 2 n \% 3 == 2 n%3==2,就把多出来的那2个给 n 2 n2 n2

所以得到公式:n1 = n / 3,n2 = n / 3 + n % 3

把它们存储到二维字符数组中,一开始初始化字符数组为空格,然后按照u型填充进去,最后输出这个数组u。

3、AC代码

#include <iostream>
#include <string.h>
using namespace std;
int main() {
    char c[81], u[30][30];
    memset(u, ' ', sizeof(u));
    scanf("%s", c);
    int n = strlen(c) + 2;
    int n1 = n / 3, n2 = n / 3 + n % 3, index = 0;
    for(int i = 0; i < n1; i++) u[i][0] = c[index++];
    for(int i = 1; i <= n2 - 2; i++) u[n1-1][i] = c[index++];
    for(int i = n1 - 1; i >= 0; i--) u[i][n2-1] = c[index++];
    for(int i = 0; i < n1; i++) {
        for(int j = 0; j < n2; j++) 
            printf("%c", u[i][j]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值