回溯法——马的遍历问题

题目描述

在5*4的棋盘中,马只能走斜“日”字。马从位置(x, y)处出发,把棋盘的每一格都走一次,且只走一次,请找出所有路径。

输入

x,y,表示马的初始位置。

输出

将每一格都走一次的路径总数,如果不存在该路径则输出“No solution!”。

样例输入

1 1
2 2

样例输出

32
No solution!

代码实现

import java.util.Scanner;

public class Main {
	//是否走过,棋盘
	static int a[][];
	//保存路径条数
	static int s;
	
	//剪枝函数
	public static boolean check(int x,int y) {
		//不在棋盘里或者走过的剪掉
		if(x>=1&&x<=5&&y>=1&&y<=4&&a[x][y]==0)
			return true;
		else
			return false;
	}
	
	public static void solve(int x,int y,int step) {
		if(step==20) {
			s++;
			return;
			}
		//方向引导数组
		int fx[] = {1,2,2,1,-1,-2,-2,-1};
		int fy[] = {2,1,-1,-2,-2,-1,1,2};
		int dx,dy;
		for(int i=0;i<=7;i++) {
			dx = x + fx[i];
			dy = y + fy[i];
			if(check(dx, dy)) {
				a[x][y] = step;
				solve(dx, dy, step+1);
				a[x][y] = 0;
			}
		}
	}
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()) {
			a = new int[10][10];
			int x = sc.nextInt();
			int y = sc.nextInt();
			for(int i=1;i<=5;i++)
				for(int j=1;j<=5;j++)
					a[i][j] = 0;
			s = 0;
			//从第一步开始
			solve(x,y,1);
			if (s == 0)
				System.out.println("No solution!");
			else

				System.out.println(s);
		}
	}
}
  • 1
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值