A1167 Cartesian Tree(30分)PAT甲级 (Advanced Level) Practice(C++)满分题解【最小堆+构建树+层序遍历】

Cartesian tree is a binary tree constructed from a sequence of distinct numbers. The tree is heap-ordered, and an inorder traversal returns the original sequence. For example, given the sequence { 8, 15, 3, 4, 1, 5, 12, 10, 18, 6 }, the min-heap Cartesian tree is shown by the figure.

Your job is to output the level-order traversal sequence of the min-heap Cartesian tree.

Input Specification:

Each input file contains one test case. Each case starts from giving a positive integer N (≤30), and then N distinct numbers in the next line, separated by a space. All the numbers are in the range of int.

Output Specification:

For each test case, print in a line the level-order traversal sequence of the min-heap Cartesian tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the beginning or the end of the line.

Sample Input:

10
8 15 3 4 1 5 12 10 18 6

Sample Output:

1 3 5 8 4 6 15 10 12 18

 

代码如下:

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
const int MAX=0x3fffffff;
struct Node{
    int data;
    Node *left,*right;
}*tree;
vector<int> nodelist;
Node* check(int low,int high)
{
    if(low<0||high<low)return NULL;//遍历完成
    Node *newtree=new Node;
    int min=low;
    for(int i=low;i<=high;i++)
        if(nodelist[i]<nodelist[min])min=i;
    newtree->data=nodelist[min];
    newtree->left=check(low,min-1);
    newtree->right=check(min+1,high);
    return newtree;
}
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        int index;
        cin>>index;
        nodelist.push_back(index);
    }
    tree=check(0,n-1);
    int flag=0;
    queue<Node*> q;
    q.push(tree);
    while(!q.empty()){
        Node *t=q.front();
        if(flag==1)cout<<" ";//只有第一个数前面不要输出空格
        else flag=1;
        cout<<t->data;
        if(t->left)q.push(t->left);
        if(t->right)q.push(t->right);
        q.pop();
    }
    return 0;
}

运行结果如下:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值