贪心算法D题

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools.
Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely.

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.

Input

  • Line 1: Two space-separated integers: N and L
  • Lines 2…N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap.

Output

  • Line 1: The miminum number of planks FJ needs to use.
    Sample Input
    3 3
    1 6
    13 17
    8 12
    Sample Output
    5

题意

告诉你多少个泥潭,以及木板固定长度,求最少用几块木板铺满所有泥潭,可以把路抽象成一维,转换成区间长度问题。
注意:题目中说泥潭不会重叠

输入
整数n表示泥潭数量,整数L表示木板长度
(1 <= N <= 10,000)
(0 <= s i , e i , L<= 1,000,000,000)

输出
最少使用的木板数量

#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int n,l;
struct road{
    int s,e;
}rd[10001];
bool cmp(road a,road b){
    return a.e<b.e;
}
int main(){
    cin>>n>>l;
    for(int i=0;i<n;i++)
        cin>>rd[i].s>>rd[i].e;
    sort(rd,rd+n,cmp);
    int t=0;
    int sum=0;
    for(int i=0;i<n;i++){
        t=max(t,rd[i].s);//取到达的最大距离,可以更节省木板数量
        if(t<rd[i].e){
            int add=ceil(1.0*(rd[i].e-t)/l);//加快计算速度
            //不需要一块一块加,算出差几块木板直接加
            t+=l*add;
            sum+=add;
        }
    }
    cout<<sum;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值