1008 Elevator

该博客主要涉及编程问题,内容是关于计算城市最高建筑中唯一电梯完成请求列表所花费的总时间。电梯上行每层耗时6秒,下行每层4秒,每站停留5秒。输入包含一个测试用例,包含一个正整数N和N个正整数,表示电梯停靠的楼层。程序通过计算得出总时间并输出。
摘要由CSDN通过智能技术生成
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:

For each test case, print the total time on a single line.
Sample Input:
3 2 3 1
Sample Output:
41

解题

lst = list(map(int, input().split(' ')))
n = lst[0]
res = 5*n
def func(a, b):
    dif = b-a
    if dif > 0:
        return 6*dif
    else:
        return 4*abs(dif)
for i in range(1, n):
    res += func(lst[i], lst[i+1])
res += func(0, lst[1])
print(res)

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Grayson Zhang

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值