How many tables HDU 1213

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

嗯…说了这么多就是 人怕陌生,想和认识的人坐一起,给你一对数字表示这两个人认识 问你要准备几张桌子…(全是英文 烦死了…)
这里用到并查集 哈哈 这是个模板题!

#include <iostream>

using namespace std;
const int N = 10010;
int s[N+1];
void inits() //初始化函数
{
    for(int i=1;i<=N;i++)
        s[i]=i;
}
int finds(int x) //查找函数
{
    return x==s[x]?x:finds(s[x]);
}
void unions(int x,int y)//合并函数 
{
    x=finds(x);
    y=finds(y);
    if(x!=y) s[x]=s[y];


}
int main()
{
    int t,m,n,x,y;
    cin>>t;
    while(t--)
    {
        cin>>m>>n;
        inits();
        while(n--)
        {
            cin>>x>>y;
            unions(x,y);
        }
        int ant=0;
        for(int i=1;i<=m;i++)
        {
            if(s[i]==i)
                ant++;
        }
        cout<<ant<<endl;
    }
    return 0;
}

这道题很简单 也不需要压缩 优化啥的 相信你接触并查集一定可以 领会的!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值