【JAVA课程作业】PTA_2022实验七(5.3)

判断+填空

在这里插入图片描述
在这里插入图片描述

7-1 创建一个倒数计数线程

创建一个倒数计数线程。要求:1.该线程使用实现Runnable接口的写法;2.程序该线程每隔0.5秒打印输出一次倒数数值(数值为上一次数值减1)。

输入格式:
N(键盘输入一个整数)

输出格式:
每隔0.5秒打印输出一次剩余数

输入样例:
6
输出样例:
在这里给出相应的输出。例如:

6
5
4
3
2
1
0

import java.util.Scanner;

class Mythread implements Runnable
{
	public static int num;
	public Mythread(int n) 
	{
		this.num=n;
	}
	
	public void run()
	{
		for(int i=num;i>=0;i--)
		{
			try
			{
				Thread.sleep(500);
			} 
			catch (Exception e) 
			{
				// TODO: handle exception
			}
			System.out.println(i);
		}
	}
}
public class Main
{
	public static void main(String[] args) 
	{
		Scanner in=new Scanner(System.in);
		int n=in.nextInt();
		Mythread m=new Mythread(n);
		Thread t=new Thread(m);
		t.start();
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

阿斯卡码

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值