2021-05-06

A tourist gets lost in the desert with n liters of water. He drinks positive integer units of water each day.

Write a program to calculate how many different ways the tourist can drink up the water.
Input
The first line contains the number of test cases T(T≤10).
Next T lines contain the number n(1≤n≤1000000) for each test case.
Output
Output consists of T lines.
Each line contains the binary number which represents number of different ways to finish up the water specified in the test case.
Sample Input
1
3
Sample Output
100

#include"stdio.h"
int main()
{
    int t,x;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&x);
        printf ("1");
        for (int i=0;i<x-1;i++)
            printf ("0");
        printf ("\n");
    }
    return 0;
}

Hint
3 liters of water can be comsumed in four different ways show in the following.

  1. 1 1 1
  2. 1 2
  3. 2 1
  4. 3

If we write 4 in binary(二进制), it’s 100.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值