2021-05-06

这篇博客探讨了一个有趣的问题:如何从一个四位素数变换到另一个四位素数,使得每次只改变一个数字,并保持路径上的所有数字都是素数,同时最小化变换的代价。文章通过一个例子展示了这个问题,并提出了一种解决方法,即使用广度优先搜索来找到最短的素数路径。同时,还提供了一个C++程序来求解这个问题。这涉及到了数学、算法和信息安全的概念。
摘要由CSDN通过智能技术生成

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.!
在这里插入图片描述

— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

#include"stdio.h"
#include"queue"
#include"string.h"
#include"algorithm"
using namespace std;
int a[100000],b[100010];
int n,m,s,f;
void init()
{
	a[1]=a[0]=1;
	for(int i=2; i<=10000; i++)
	{
		if(!a[i])
			for(int j=i*i; j<=10000; j+=i)
				a[j]=1;
	}
}
struct dd
{
	int x,z;
} t1,t2;
void bfs()
{

	memset(b,0,sizeof(b));
	queue<dd>q;
	t1.x=n;
	t1.z=0;
	q.push(t1);
	while(!q.empty())
	{
		t1=q.front();
		q.pop();
		for(int j=0; j<4; j++)
		{
			int i;
			t2.z=t1.z+1;
			if(j==0)//个位
			{
				for(i=0; i<=9; i++)
					if(!a[t1.x/10*10+i]&&!b[t1.x/10*10+i])
					{
						t2.x=t1.x/10*10+i;
						if(t2.x==m&&t2.z<s)//
						{
							s=t2.z;
							f=0;
						}
						b[t2.x]=1;
						
						q.push(t2);
					}
			}
			else if(j==1)//十位
			{
				for(i=0; i<=9; i++)
					if(!a[t1.x/100*100+i*10+t1.x%10]&&!b[t1.x/100*100+i*10+t1.x%10])
					{
						t2.x=t1.x/100*100+i*10+t1.x%10;
						if(t2.x==m&&t2.z<s)//
						{
							s=t2.z;
							f=0;
						}	
						b[t2.x]=1;
						q.push(t2);
					}
			}
			else if(j==2)//百位
			{
				for(i=0; i<=9; i++)
					if(!a[t1.x/1000*1000+i*100+t1.x%100]&&!b[t1.x/1000*1000+i*100+t1.x%100])
					{
						t2.x=t1.x/1000*1000+i*100+t1.x%100;
						if(t2.x==m&&t2.z<s)//
						{
							s=t2.z;
							
							f=0;
						}//printf("$$%d\n",t2.x);
						b[t2.x]=1;
						q.push(t2);
					}
			}
			else if(j==3)//千位
			{
				for(i=1; i<=9; i++)
					if(!a[i*1000+t1.x%1000]&&!b[i*1000+t1.x%1000])
					{
						t2.x=i*1000+t1.x%1000;
						if(t2.x==m&&t2.z<s)//
						{
							s=t2.z;
							f=0;//print(t2);
						}
						b[t2.x]=1;
					//	q[t2]=t1;
						q.push(t2);
					}
			}
		}
	}
	return;
}
int main()
{
	int i,j,k,t;
	scanf("%d",&t);
	init();
	while(t--)
	{
		scanf("%d%d",&n,&m);
		s=9999999;
		f=1;
		if(n==m)
		{
			printf("0\n");
			continue;
		}
		bfs();
		if(f)
			printf("Impossible\n");
		else
			printf("%d\n",s);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值