PAT-Java-1006-Sign In and Sign Out (25)

1006. Sign In and Sign Out

题目阐述

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133


题目分析

题目非常简单,直接使用字符串比较一下子就出来了,附上代码;

package PAT;

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner s = new Scanner(System.in);
        int N = s.nextInt();
        String[][] info = new String[N][3];
        for(int i=0; i<N; i++) {
            info[i][0] = s.next();
            info[i][1] = s.next();
            info[i][2] = s.next();
        }
        String min = info[0][1], max = info[0][2];
        int index1 = 0;
        for(int i=0; i<N; i++) {
            if(info[i][1].compareTo(min) < 0) {
                min = info[i][1];
                index1 = i;
            }
        }
        int index2 = 0;
        for(int i=0; i<N; i++) {
            if(info[i][2].compareTo(max) > 0) {
                max = info[i][2];
                index2 = i;
            }
        }
        System.out.println(info[index1][0] + " " + info[index2][0]);
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值