PTA甲级题——1012 The Best Rank (25 分)(排序)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
#include<iostream>
#include<cstring>
#include<algorithm>
struct node{
	int id;
	//A C M E 
	int grace[5];
	int rank[5];
}pre[2005];
int n,m;
using namespace std;
int tmp=0;
bool cmp(node x,node y){
	return x.grace [tmp]>y.grace [tmp];
}
int main(){
	cin>>n>>m;
	for(int i=0;i<n;i++){
		cin>>pre[i].id >>pre[i].grace [1]>>pre[i].grace [2]>>pre[i].grace [3];
		pre[i].grace [0]=(pre[i].grace [1]+pre[i].grace [2]+pre[i].grace [3])/3;
	}
	for(int i=0;i<4;i++){
		tmp=i;
		sort(pre,pre+n,cmp);
		for(int j=0;j<n;j++){
			pre[j].rank [i]=j+1;
		}
		for(int j=1;j<n;j++){
			if(pre[j].grace [i]==pre[j-1].grace[i])
			    pre[j].rank [i]=pre[j-1].rank [i];
		}
	}
//	for(int i=0;i<n;i++){
//		cout<<pre[i].id <<endl;
//		for(int j=0;j<4;j++){
//			cout<<pre[i].rank [j]<<" ";
//		}
//		cout<<endl;
//	}
    char cp[5]={'A','C','M','E'};
    while(m--){
    	int ID;
    	cin>>ID;
    	int Min=0;
		int tmp=0;
		bool flag=0;
		for(int i=0;i<n;i++){
			if(pre[i].id ==ID){
				flag=1;
				tmp=i;
				break;
			}
		}
		if(!flag){
			cout<<"N/A"<<endl;
			continue;
		}
		for(int i=1;i<4;i++){
			if(pre[tmp].rank [i]<pre[tmp].rank [Min]){
				Min=i;
			}
		}
		cout<<pre[tmp].rank [Min]<<" "<<cp[Min]<<endl;
	}
	return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值