在xcode 6.4 中使用swift和object-c混合编程,同时通过cocoapods进行管理的一些问题和解决办法

  • 使用cocoapods 中的use_frameworks! 产生.h文件无法发现的问题
    因为使用到SwiftyJSON这个第三方库来进行json的解析,并且版本是2.2.1。需要在PodFile里面使用use_frameworks!才能安装
platform :ios, '8.0'
use_frameworks!

pod 'ArcGIS-Runtime-SDK-iOS' , '10.2.4'

#用于主界面右下角的about按钮被点击后,滑动显示管用窗口
pod 'PPRevealSideViewController', '~> 1.2.1'
pod 'SwiftyJSON', '~> 2.2.1'

但是这样会产生一个在原来的 iLiveTraffic-Bridging-Header.h 桥接文件

// 建立调用PPRevealSideViewController工具包的桥接 - begin
#import "PPRevealSideViewController.h"
// 建立调用PPRevealSideViewController工具包的桥接 - end

// 建立调用 AFNetWorking 工具包的桥接 -begin
#import "AFNetWorking.h"
// 建立调用 AFNetWorking 工具包的桥接 -end

无法编译,报告PPRevealSideViewController.h没有发现的错误。

如果在PodFile里面去掉use_frameworks!和pod ‘SwiftyJSON’, ‘~> 2.2.1’则项目可以正常运行。
说明这个问题是由于 use_frameworks!引起的。
经过一天的google。发现了这个博文
http://www.innerexception.com/2015/05/cocoapods-useframeworks-means-bridging.html
大致意思是:
如果在cocoapods 里面不使用 use_frameworks!,则是通过static libraries 这个方式来管理pod的代码。这样就需要在app-Bridging-Header.h 文件里面去import相应的.h 文件。而如果使用了use_frameworks!,则cocoapods 使用了frameworks 来取代static libraries 方式。
这样的话,我们就可以通过下面3个步骤去解决这个问题。

  • 在PodFile中使用 use_frameworks!,让cocoapods来使用framework的方式
  • pod update 成功好以后,打开workspace文件
  • 在Project > General > Linked Framework and Libraries >
    增加 SwiftyJSON 的framework,如下图:

配置framework
- 修改iLiveTraffic-Bridging-Header.h文件,去掉已经frame化的桥接


#ifndef iLiveTraffic_Bridging_Header_h
#define iLiveTraffic_Bridging_Header_h

// 建立调用讯飞工具包的桥接 - begin
#import "iflyMSC/IFlySpeechRecognizerDelegate.h"
#import "iflyMSC/IFlySpeechRecognizer.h"
#import "iflyMSC/IFlyRecognizerViewDelegate.h"
#import "iflyMSC/IFlyRecognizerView.h"
#import "iflyMSC/IFlyContact.h"
#import "iflyMSC/IFlyUserWords.h"

#import "iflyMSC/IFlyDataUploader.h"
#import "iflyMSC/IFlyDataDownloader.h"

#import "iflyMSC/IFlySpeechSynthesizerDelegate.h"
#import "iflyMSC/IFlySpeechSynthesizer.h"

#import "iflyMSC/IFlySpeechUtility.h"
#import "iflyMSC/IFlySpeechConstant.h"
#import "iflyMSC/IFlySpeechError.h"

#import "iflyMSC/IFlySpeechUnderstander.h"
#import "iflyMSC/IFlyTextUnderstander.h"

#import "iflyMSC/IFlySetting.h"
// 建立调用讯飞工具包的桥接 - end

// 建立调用PPRevealSideViewController工具包的桥接 - begin
//#import "PPRevealSideViewController.h" //已经通过cocoapods的use_frameworks!来进行管理,不需要建立桥接了
// 建立调用PPRevealSideViewController工具包的桥接 - end

// 建立调用 AFNetWorking 工具包的桥接 -begin
//#import "AFNetWorking.h"              //已经通过cocoapods的use_frameworks!来进行管理,不需要建立桥接了
// 建立调用 AFNetWorking 工具包的桥接 -end

#endif
  • 修改所有需要使用这个frame功能的swift文件,都需要
import PPRevealSideViewController
import AFNetworking
  • 原有的调用可能会改变
    • 原有的:
var manager:AFHTTPRequestOperationManager = Tools.getAFHTTPRequestOperationManager()
 - 现在的
var manager:AFNetworking.AFHTTPRequestOperationManager = Tools.getAFHTTPRequestOperationManager()
  • 0
    点赞
  • 0
    收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:创作都市 设计师:CSDN官方博客 返回首页
评论 1

打赏作者

remote_roamer

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值