hdu 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19251    Accepted Submission(s): 8599


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining

解题思路:
素数打表,因为n最大是20,所以只要打到40
用DFS进行搜索,然后用vis进行标记,搜索过还需要回溯,为了查找下一组数据,本题数据比较水,不需要简直都可以过
最后还要注意格式:两个数之间要有空格,每组数据要有空行

#include<stdio.h>
#include<cstring>
using namespace std;

int prime[40]={0,1,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};//素数打表,因为n最大是20,所以只要打到40
int vis[21],a[21],N;

void dfs(int num)
{
	if(num==N&&prime[a[num-1]+a[0]])
	{
		for(int i=0;i<num-1;i++)
			printf("%d ",a[i]);
		printf("%d\n",a[num-1]);
	}
	else
	{
		for(int i=2;i<=N;i++)
		{
			if(vis[i]==0)
			{
				if(prime[i+a[num-1]])
				{
					vis[i]=1;
					a[num++]=i;
					dfs(num);
					vis[i]=0;
					num--;
				}
			}
		}
	}
}

int main()
{
	int num=1;
	while(scanf("%d",&N)!=EOF)
	{
		printf("Case %d:\n",num++);
		memset(vis,0,sizeof(vis));
		a[0]=1;
		dfs(1);
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值