hdu2035 乘方取余

人见人爱A^B

[url]http://acm.hdu.edu.cn/showproblem.php?pid=2035[/url]

Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。

Sample Input
2 3
12 6
6789 10000
0 0

Sample Output
8
984
1

解题思路
这是用同余规律的题目,加上一些递归思想。
(x * x) % 1000 == (x % 1000) * (x % 1000) % 1000


#include <stdio.h>
#include <stdlib.h>

// 核心算法
// 将a^b转化为a^(b/2) * a^(b/2)
// 当b为奇数时,ans * a
// 乘方的结果不断mod 1000,不影响最后结果
int pow_mod(int a, int b)
{
int x, ans;

if (b == 1) return a;
x = pow_mod(a, b/2);
ans = x * x % 1000;
if (b % 2 == 1) {
ans = ans * a % 1000;
}

return (int)ans;
}

int main (int argc, char const* argv[])
{
int a, b;

while (1) {
scanf("%d %d", &a, &b);
if (a == 0 && b == 0) break;
printf("%d\n", pow_mod(a, b));
}

return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值