1004. Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1
这题做下来并不难,但是坑爹,
ID K ID[1] ID[2] ... ID[K]

上面那行的输入不是按id顺序由小到大排列的。是随便来的。。。。巨坑。

#include <stdio.h>
#include <stdlib.h>
#include <stdbool.h>

#define MAXSIZE 100

struct node
{
    int father;
    int level;
    bool child;
};

typedef struct node treeNode;

int main()
{
    int numNodes, NLNodes, childs, i, papa, j, son;

    /**< 读取输入部分 */
    scanf("%d %d", &numNodes, &NLNodes);
    
    /**< 读入结点数量后,就开一个treeNode数组并初始化 */
    treeNode tree[numNodes+1];
    for(i=0; i<=numNodes; i++)
    {
        tree[i].father = -1;
        tree[i].child = false;
        tree[i].level = -1;
    }
    tree[1].father = -1;
    tree[1].level = 1;

    
    for(i=0; i<NLNodes; i++)
    {
        scanf("%d %d", &papa, &childs);
        if(childs>0)
        {
            tree[papa].child = true;
        }
        for(j=0; j<childs; j++)
        {
            scanf("%d", &son);
            tree[son].father = papa;
            /**<  本来是打算在输入同时,完成对层级的输入,但是id输入不按顺序来,那只能下面再用一个循环来给层级赋值*/
            //tree[son].level = tree[papa].level + 1; 
        }
    }

    /**< 读取完成 */
    for(i=2; i<=numNodes;i++)
    {
        tree[i].level = tree[tree[i].father].level + 1;
        //printf("%d in level %d\n", i, tree[i].level);
    }

    /**< 计算最大层数,注意这里不一定和非叶结点数量相等 */
    int lvl, cnt , lvNum =0;
    for(i=1; i<=numNodes;i++)
    {
        if(tree[i].level>lvNum)
        {
            lvNum = tree[i].level;
        }
    }

    
    for(lvl=1; lvl<=lvNum;lvl++)
    {/**< 遍历所有层级 */
        cnt = 0;
        
        for(i=1; i<=numNodes; i++)
        {/**< 遍历所有结点,和当前层级相等且无儿子就给计数器++ */
            if(tree[i].level==lvl && tree[i].child == false)
                cnt++;
        }
        /**< 输出格式控制 */
        if(lvl!=1)
        {
            printf(" ");
        }
        printf("%d", cnt);
    }

    system("pause");
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值