ZZULI_SummerPractice(6)  POJ 270…

Time Limit: 1000MSMemory Limit: 65536K64bit IO Format: %I64d & %I64u

[Submit  [Go Back  [Status]

Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.


Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.
ZZULI_SummerPractice(6) <wbr> <wbr>POJ <wbr>2704 <wbr> <wbr>Pascal's <wbr>TravelsZZULI_SummerPractice(6) <wbr> <wbr>POJ <wbr>2704 <wbr> <wbr>Pascal's <wbr>Travels
Figure 1
Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2 63 paths for any board.

Sample Input


2331 
1213 
1231 
3110 

3332 
1213 
1232 
2120 

11101 
01111 
11111 
11101 
11101 
-1

Sample Output



7

Hint

Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as long values in Java or long long values using the contest's C/C++ compilers.  
题意就是给你一个迷宫,然后每个格子里面有个数值,到该数值的时候你要跳相应的步数,但是不能跳出迷宫的范围,深搜的话容易超时,这里介绍DP,直接秒杀,跳到该格子时,把要跳到的格子对应值直接加上,最后那个就是了
代码:
#include<stdio.h>
#include<string.h>
char map[55][55];
int n;
__int64 num[50][50];
int main()
{
int i,j,k;
while(scanf("%d",&n),n!=-1)
{
for(i=0;i<n;i++)
scanf("%s",map[i]);
memset(num,0,sizeof(num));
num[0][0]=1;
for(i=0;i<n;i++)
for(j=0;j<n;j++)
{
k=map[i][j]-'0';
if(k==0)continue;
if(j+k<n)
num[i][j+k]+=num[i][j];
if(i+k<n)
num[i+k][j]+=num[i][j];
}
printf("%I64d\n",num[n-1][n-1]);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值