[Android]依赖了包含aar包的库后出现Failed to resolve库aar包问题的解决办法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/runstoppable/article/details/72743888

Android Studio中创建一个module或者导入一个module的时候,如果这个module中依赖了aar库,当build工程的时候,会出现failed to resolve这个错误

这时候,只要在app的build.gradle中加入下面代码就可以完美解决了:

[java] view plain copy
  1. repositories {  
  2.     flatDir {  
  3.         dirs project(':taesdk').file('libs')  
  4.     }  
  5. }  

上面代码中的“taesdk“替换成module的名字,libs是module依赖的aar库所在的目录。如下:

[java] view plain copy
  1. apply plugin: 'com.android.application'  
  2.   
  3. android {  
  4.     compileSdkVersion 25  
  5.     buildToolsVersion "25.0.0"  
  6.     defaultConfig {  
  7.         applicationId "com.paxsz.ossdemo"  
  8.         minSdkVersion 19  
  9.         targetSdkVersion 25  
  10.         versionCode 1  
  11.         versionName "1.0"  
  12.         testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"  
  13.     }  
  14.     buildTypes {  
  15.         release {  
  16.             minifyEnabled false  
  17.             proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'  
  18.         }  
  19.     }  
  20. }  
  21. repositories {  
  22.     flatDir {  
  23.         dirs project(':taesdk').file('libs')  
  24.     }  
  25. }  
  26. dependencies {  
  27.     compile fileTree(include: ['*.jar'], dir: 'libs')  
  28.     androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {  
  29.         exclude group: 'com.android.support', module: 'support-annotations'  
  30.     })  
  31.     compile 'com.android.support:appcompat-v7:25.0.1'  
  32.     testCompile 'junit:junit:4.12'  
  33.     compile project(':taesdk')  
  34. }  

这时候再去编译,就不会出错了
展开阅读全文

没有更多推荐了,返回首页