Hurry Up

Problem Description

GG is some what afraid of his MM. Once his MM asks, he will always try his best to rush to their home. 
Obvious, he can run home in straight line directly. Alternatively, he can run to the main road and call the taxi.
You can assume there is only one main road on the x-axis, with unlimited length.
Given the initial location of GG and his destination, please help to ask the minimize time to get home.
GG will always run at the fixed speed of vr, and the taxi can move at the fixed speed of vt 
You can also assume that, only GG reach the main road, he can catch the taxi immediately. And the taxi will go towards home ( not necessay along the road ). 
Bisides, GG can run arbitrary length, and pay arbitrarily for the taxi.

Input

Multiple test cases. First line, an integer T(1<=T<=2000), indicating the number of test cases. 
For each test cases, there are 6 integers x1, y1, x2, y2, vr, vt in a line. 
( -1000 <= x1, y1, x2, y2 <= 1000, 1 <= vr < vt <= 1000 ) 
(x1, y1) : the initial location of GG 
(x2, y2) : the destination location of GG 
vr: GG's run speed 
vt: taxi's speed

Output

For each test case, output a real number with 2 digits after the arithmetic point. It is the shorest time for GG to reach home.

Sample Input

2
1 1 2 2 1 2
1 1 2 2 1 7

Sample Output

1.41
1.32
 
 
 
 
/*  
三分法
      类似二分的定义Left和Right
      mid = (Left + Right) / 2
      midmid = (mid + Right) / 2;
      如果mid靠近极值点,则Right = midmid;       语句一
      否则(即midmid靠近极值点),则Left = mid;     语句二
*/
#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int x1,x2,y11,y22,vr,vt;
double sqt(int x1,int y11,int x2,int y22)
{
    return sqrt((x1-x2)*(x1-x2)+(y11-y22)*(y11-y22));  
}
double fun(int x)
{
     return sqt(x1,y11,x,0)/vr+sqt(x2,y22,x,0)/vt;  
}
int main()
{
	int t;  
	double mid1,mid2,l,h,n;
	cin>>t;
	while(t--)
	{
		cin>>x1>>y11>>x2>>y22>>vr>>vt;
        n=sqt(x1,y11,x2,y22)/vr;
		if(x1<x2) swap(x1,x2);
		l=x1; h=x2;
		while(h-l>1e-8)    // 在x轴上找到一点x,使得速度最小
		{
		   mid1=(l+h)/2;
		   mid2=(mid1+h)/2;
		   if(fun(mid1)<fun(mid2)) h=mid2;  //  语句一
		   else l=mid1;                    //  语句二
		}
		printf("%.2lf\n",n<fun(l)?n:fun(l));
	}
 return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值