hdu 5587(算法之二分)

                                                    Array

                                                 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                   Total Submission(s): 170    Accepted Submission(s): 87


Problem Description
Vicky is a magician who loves math. She has great power in copying and creating.
One day she gets an array {1}。 After that, every day she copies all the numbers in the arrays she has, and puts them into the tail of the array, with a signle '0' to separat.
Vicky wants to make difference. So every number which is made today (include the 0) will be plused by one.
Vicky wonders after 100 days, what is the sum of the first M numbers.
 

Input
There are multiple test cases.
First line contains a single integer T, means the number of test cases. (1T2103)
Next T line contains, each line contains one interger M. (1M1016)
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
3 1 3 5
 

Sample Output
  
  
1 4 7
 

Source
BestCoder Round #64 (div.2)


这道题是经典二分,需要对二分有比较深刻的理解。
简单的说就找规律吧。
令k[i]储存每次操作后的数的个数,k1[i]储存i操作后的所有数总和。
则有:
          
  k[0]=1;
     k1[0]=1;
    for(int i=1;i<58;i++)
    {
        k[i]=k[i-1]*2+1;
        k1[i]=k1[i-1]*2+(long long)1<<i);   记住此处括号必不可少,<<的优先级比+号小。并且要把1强制转化成long long  型
    }


接下来就是二分的事了,
1.查找到正好不大于n的k[i]值、由上易知前k[i]位的总和由k1[i]储存。即只需要求后n-k[i]位的值的总和
2.后面的为新增序列,则每一位都加了1,若减去1,并且去掉n+k[i]+1的0,则可将n+k[i]+2——n看做是1——n-k[i]-1位得总和,则又回到步骤1.
 while(n>0)
        {
            int m=lower_bound(k,k+57,n)-k;
            while(k[m]>n)m--;
            n-=k[m];
            res+=k1[m];
            if(n>0)
            {
                 res+=n;
                 n--;
            }
        }


完整代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll k[111],k1[111];
int main()
{
    int T;
     k[0]=1;
     k1[0]=1;
    for(int i=1;i<58;i++)
    {
        k[i]=k[i-1]*2+1;
        k1[i]=k1[i-1]*2;
        k1[i]+=(ll)1<<i;
    }
    while(scanf("%d",&T)!=EOF)
    while(T--)
    {
        ll n;
        scanf("%lld",&n);
        ll res=0;
        while(n>0)
        {
            int m=lower_bound(k,k+57,n)-k;
            while(k[m]>n)m--;
            n-=k[m];
            res+=k1[m];
            if(n>0)
            {
                 res+=n;
                 n--;
            }
        }
        printf("%lld\n",res);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值