B - Milk Patterns (求可重叠最长k次重复子串,后缀数组+二分)

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least Ktimes.

Input

Line 1: Two space-separated integers: N and K 
Lines 2.. N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

题意:给出一个串,以及次数k,要求找出一个最长的重复至少k次的可重叠子串。

思路:

  • 利用后缀数组求出height数组,由于长度要尽可能长,二分长度l,对于每个l,遍历height,如果有一段区间的每个height都大于等于l,则说明这些串的lcp都大于等于l,比较这段区间长度(即该前缀出现次数)是否大于等于k。是则说明有一个子串出现了至少k次。
  • 如果找到height值小于l,则重新开始记录下一段区间。
#include<iostream>
#include<queue>
#include<cstring>
#include<math.h>
#include<algorithm>
#include<cstdio>
#include<map>
#include<stack>
#include<vector>
#define rep(i,e) for(int i=0;i<(e);++i)
#define rep1(i,e) for(int i=1;i<=(e);++i)
#define repx(i,x,e) for(int i=(x);i<=(e);++i)
#define pii pair<int,int>
#define X first
#define Y second
#define PB push_back
#define MP make_pair
#define mset(var,val) memset(var,val,sizeof(var))
#define IOS ios::sync_with_stdio(false);cin.tie(0)
typedef long long ll;
using namespace std;

#ifdef LOCAL
template<typename T>
void dbg(T t){
    cout<<t<<" "<<endl;
}
template<typename T, typename... Args>
void dbg(T t, Args... args){
    cout<<t<<" ";dbg(args...);
}

#else
#define dbg(...)
#endif // local
typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int mod = 1e9+7;
const int N = 1e4+10;
typedef long long ll;
#define K 137
const int maxn = 2e6+10;
const int maxm =4e5+10;

int num[maxn];
int sa[maxn],x[maxn],y[maxn],rnk[maxn],c[maxn],height[maxn];

void build_sa(int s[],int n,int m){
    int i,j,p = 0;
    for(i = 0; i < m; i++) c[i] = 0;
    for(i = 0; i < n; i++) c[x[i] = s[i]]++;
    for(i = 1; i < m; i++) c[i] += c[i-1];
    for(i = n-1; i >= 0; i--) sa[--c[x[i]]] = i;

    for(int k = 1; k <= n; k <<= 1){
        p = 0;
        for(i = n-k; i < n; i++) y[p++] = i;
        for(i = 0; i < n; i++)
            if(sa[i] >= k)
                y[p++] = sa[i] - k;
        for(i = 0; i < m; i++) c[i] = 0;
        for(i = 0; i < n; i++) c[x[y[i]]]++;
        for(i = 1; i < m; i++) c[i] += c[i-1];
        for(i = n-1; i >= 0; i--) sa[--c[x[y[i]]]] = y[i];
        swap(x,y);
        p = 1; x[sa[0]] = 0;
        for(i = 1; i < n; i++)
            x[sa[i]] = y[sa[i]] == y[sa[i-1]] && y[sa[i]+k] == y[sa[i-1]+k] ? p-1 : p++;
        if(p >= n)
            break;
        m = p;
    }
}

void getHeight(int s[],int n){
    int i,j,k = 0;
    for(i = 0; i <= n; i++) rnk[sa[i]] = i;
    for(i = 0; i < n; i++){
        if(k) k--;
        int j = sa[rnk[i]-1];
        while(s[i+k] == s[j+k]) k++;
        height[rnk[i]] = k;
    }
}

int check(int k,int n){
    int cnt = 0;
    int ccnt = 1;
    for(int i = 0; i <= n; i++){
       if(height[i] < k){
            cnt = max(cnt,ccnt);
            ccnt = 1;
            continue;
       }
       else{
            ccnt++;
       }
    }
    cnt = max(cnt,ccnt);
    return cnt;
}

void work(){
    int n,k;
    while(cin>>n>>k){
        for(int i = 0; i < n; i++){
            cin>>num[i];
        }
        build_sa(num,n+1,1000010);
        getHeight(num,n);
        int res = 0;
        int l = 0,r = n;
        while(l <= r){
            int m = (l+r) >> 1;
            if(check(m,n) >= k){
                res = m;
                l = m+1;
            }
            else{
                r = m-1;
            }
        }
        cout<<res<<endl;
    }
}

int main()
{
#ifdef LOCAL
    freopen("in.txt","r",stdin);
#endif // LOCAL
    work();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值