二分贪心练习--T(用最少的箱子放所有的货物)

题目描述:

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program. 

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros. 

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file. 

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 
题目大意:

有6*6的盒子,然后有1*1,2*2,3*3,4*4,5*5,6*6的货物,求用最少的箱子数能将货物全部装好。

解题思路:贪心问题。

由题意可知,6*6,5*5,4*4每一个都需要用一个单独的箱子。5*5的货物装完,每个箱子还可以装11个1*1的货物。4*4的货物装完,还可以装5个2*2的货物,3*3的货物装完,还有空位即可装如代码所示num[4]的2*2的货物。所以求完箱子(3*3以上的)后,将2*2的装完,剩下的空间用于装1*1的货物。

源代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
using namespace std;
int num[4]={0,5,3,1};
int dingdan[7];
int main()
{
    while (scanf("%d%d%d%d%d%d",&dingdan[1],&dingdan[2],&dingdan[3],&dingdan[4],&dingdan[5],&dingdan[6])!=EOF)
    {
        if (dingdan[1]==0&&dingdan[2]==0&&dingdan[3]==0&&dingdan[4]==0&&dingdan[5]==0&&dingdan[6]==0)
            break;
        dingdan[0]=0;
        int left_2=0;
        int left_1=0;
        int sum=0;
        sum=dingdan[6]+dingdan[5]+(dingdan[3]+3)/4+dingdan[4];//6*6,5*5,4*4,3*3需要的箱子总数
        left_2=dingdan[4]*5+num[dingdan[3]%4];// 剩余的空间可以装多少2*2的货物
        /*
        if (dingdan[3]%4==1)
            left_2+=5;
        else if (dingdan[3]%4==2)
            left_2+=3;
        else if (dingdan[3]%4==3)
            left_2+=1;
        else if (dingdan[3]%4==0)
            left_2+=0;
         */
        if (dingdan[2]>left_2)
        {
            /*if ((dingdan[2]-left_2)%9==0)
                sum+=(dingdan[2]-left_2)/9;
            else
                sum+=(dingdan[2]-left_2)/9+1;
            */sum+=(dingdan[2]-left_2+8)/9;
        }
        left_1=sum*36-dingdan[6]*36-dingdan[5]*25-dingdan[4]*16-dingdan[3]*9-dingdan[2]*4;//求装完所有的货物之后,剩下多少空间可以放1*1的货物。
        if (dingdan[1]>left_1)
            sum+=(dingdan[1]-left_1+35)/36;
        printf ("%d\n",sum);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值