B - 02

Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 


Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1


Scenario #2:
impossible


Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

解题思路:看骑士能否走遍整个棋盘,每个地方自能走一次,如果可以找出按字典序排列最小的路径,所以题目用深搜,查找时按字典序查找保证最先找到的即字典序最小的,所以找到后立即输出,题目中因为把行和列弄混了,所以错了多次

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;,
int p,q,cas,ff; //p为行(数字1。。。。。p),q为列(字符A。。。),ff记录是否找到路径
bool ok[30][30];//记录行走过路线情况
struct cc{
	int c1;char c2;
}ch[600];
int dx[8]={-1,1,-2,2,-2,2,-1,1};
int dy[8]={-2,-2,-1,-1,1,1,2,2}; //按字典序的8个方向
void print()
{
	cout<<"Scenario #"<<cas<<":"<<endl;
	for(int i=1;i<=p*q;i++)
	cout<<ch[i].c2<<ch[i].c1;
	cout<<endl;
}
void solve(int x,int y,int num)
{
	ch[num].c1=x;
	ch[num].c2='A'+y-1;
	if(num==p*q) {  //找到路径
		ff=1;return;
	}  
	for(int i=0;i<8;i++)
	{
		if(x+dx[i]>0&&x+dx[i]<=p&&y+dy[i]>0&&y+dy[i]<=q&&ok[x+dx[i]][y+dy[i]]==false&&ff==0) //未越界,未到达过且未找到路径
		{
			ok[x+dx[i]][y+dy[i]]=true;
			solve(x+dx[i],y+dy[i],num+1);
			ok[x+dx[i]][y+dy[i]]=false;
		}
	}
}
int main()
{
	int n;
	cin>>n;
	ch[0].c1='A'; ch[0].c2='1';
	for(cas=1;cas<=n;cas++)
	{
		scanf("%d%d",&p,&q);
		memset(ok,false,sizeof(ok));
		ff=0; 
		ok[1][1]=true;
		solve(1,1,1);
		if(ff)
		print();
		else
		{
			cout<<"Scenario #"<<cas<<":"<<endl;
			cout<<"impossible"<<endl;
		}
		if(cas!=n) cout<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值