hdu 4283 You Are the One(区间DP)题目转换难,状态难,。。。

1、http://acm.hdu.edu.cn/showproblem.php?pid=4283

2、题目大意:

有n个男孩,现在要一个一个的登台,每个男孩都有一个diaosi值,如果他是第k个登台的,他的最终的diaosi值就等于他的diaosi值*(k-1),他前边等待了K-1个人,现在要确定一个登台顺序 ,使得所有男孩的diaosi值最小

3、思路分析

设状态dp[i][j]表示i-j区间内i是第k个登台的

 dp[s][e]=min(dp[s][e],dp[s+1][e]+a[s]*(e-s));//s是最后一个选出来的
            dp[s][e]=min(dp[s][e],dp[s+1][e]+Delay(s,e));//第一个被选出来
            for(int k=s+1;k<=e;k++)
            {
                dp[s][e]=min(dp[s][e],dp[s+1][k]+dp[k+1][e]+a[s]*(k-s)+Delay(k,e)*(k-s+1));
                //最后是k-s+1,k后边的人还要等k
            }

4、题目:

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1351    Accepted Submission(s): 637


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?


 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)


 

Output
  For each test case, output the least summary of unhappiness .


 

Sample Input
  
  
2    5 1 2 3 4 5 5 5 4 3 2 2


 

Sample Output
  
  
Case #1: 20 Case #2: 24


 

Source


 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  4267 4268 4269 4270 4271

 

5、AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 105
#define INF 1<<29
int a[N],sum[N];
int dp[N][N];//dp[i][j]表示i是第k个被选出来的
int Delay(int s,int e)
{
    if(s>e)
    return 0;
    return sum[e]-sum[s];
}
void DP(int n)
{
    for(int i=0;i<=n;i++)
    {
        for(int  j=0;j<=n;j++)
        dp[i][j]=INF;
    }
    for(int i=0;i<=n;i++)
    {
        dp[i][i]=0;
    }
    for(int d=1;d<=n;d++)
    {
        for(int i=1;i+d-1<=n;i++)
        {
            int s=i;
            int e=i+d-1;
            //int delay=Delay(s,e);
            dp[s][e]=min(dp[s][e],dp[s+1][e]+a[s]*(e-s));//s是最后一个选出来的
            dp[s][e]=min(dp[s][e],dp[s+1][e]+Delay(s,e));//第一个被选出来
            for(int k=s+1;k<=e;k++)
            {
                dp[s][e]=min(dp[s][e],dp[s+1][k]+dp[k+1][e]+a[s]*(k-s)+Delay(k,e)*(k-s+1));
                //最后是k-s+1,k后边的人还要等k
            }
        }
    }
}
int main()
{
    int t,n,cas=0;
    scanf("%d",&t);
    while(t--)
    {
        cas++;
        scanf("%d",&n);
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        DP(n);
        printf("Case #%d: %d\n",cas,dp[1][n]);
    }
    return 0;
}
/*
20
5
1 2 3 4 5
5
5 4 3 2 2
6
1 1 1 1 1 1
7
7 7 7 7 7 7 7
*/


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值