Junk-Mail Filter(并查集,删除结点,虚父节点)

点击打开链接

1、题目大意、:

给定一些关系,M开头的是2者之间有关系,s开头的是要删除此节,需注意只是删除此节点,不删除与此节点关联的所有关系,需要虚父节点,

2、第一遍错了,runtime erro,改正,数组开小了

3、题目:

Junk-Mail Filter 

Time Limit : 15000/8000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 9   Accepted Submission(s) : 2

Problem Description
 
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

 


Input
 
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

 


Output
 
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

 


Sample Input

5 6M 0 1M 1 2M 1 3S 1M 1 2S 33 1M 1 20 0
 


Sample Output

Case #1: 3Case #2: 2
 


Source
 
2008 Asia Regional Hangzhou


 

4、代码:
/*删除某个节点时,不是将与此节点所有关系都删除,只是将此节点隐藏,
别的结点的父节点还可以是此节点,用replace【】表示修改后的结点,例如,
原来结点是1、2、3,删除2结点,最后的1、2、3结点经replace【1、2、3】后
存的虚结点为1、4、3;即删除的结点用replace【i】=n++;然后看最终合并后的
每个结点的父节点,如果父节点相同,则在同一集合内,可以用flag【】来看有多少
不同的父节点,即多少不同的集合*/
#include<stdio.h>
#include<string.h>
int set[1000005];
int replace[1000005];
char op;
int flag[1000005];
int find(int x)
{
    int r=x;
    while(r!=set[r])
    r=set[r];
    int i=x;
    while(i!=r)
    {
        int j=set[i];
        set[i]=r;
        i=j;
    }
    return r;
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
        set[fx]=fy;
}
int main()
{
    int n,m,a,b,c;
    int cases=0;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        break;
        getchar();//注意
        cases++;
        int bb=n;//虚结点初始值
        for(int i=0;i<n;i++)
        {
            set[i]=i;
            replace[i]=i;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%c",&op);
            if(op=='M')
            {
                scanf("%d%d",&a,&b);
                 getchar();
                merge(replace[a],replace[b]);
            }
            else
            {
                scanf("%d",&c);
                replace[c]=bb;
                set[bb]=bb;//新虚结点给定初始父节点,类似于set[i]=i;
                bb++;
                getchar();
            }
        }
        int count=0;
        memset(flag,0,sizeof(flag));
        for(int i=0;i<n;i++)
        {
            if(flag[find(replace[i])]==0)
            {flag[find(replace[i])]=1;
            count++;
            }
        }
        printf("Case #%d: %d\n",cases,count);
    }
    return 0;
}
/*
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0
*/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值