poj 3356 AGTC(lcs 变形题)

1、http://poj.org/problem?id=3356

2、题目大意:

给定两个字符串,目的是将第一串转换成和第二串相同的字符串,可以有三种操作,1、可以有增加、删除和改变的操作,删除即如果y中有,x没有,则在同位置y中可以删去,改变是指,x中的字符可以改成跟Y中的字符一样的,求得是最少几步可以将x字符串转换成y字符串

   此题类似于求最长公共子序列,状态转移方程为

                    if(a[i-1]==b[j-1])
                    dp[i][j]=minn(dp[i-1][j-1],dp[i-1][j]+1,dp[i][j-1]+1);
                else
                    dp[i][j]=minn(dp[i-1][j-1],dp[i-1][j],dp[i][j-1])+1;

题目:

AGTC
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7633 Accepted: 3037

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where nm.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

 

4、代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define aa 0x7fffffff
int dp[1005][1005];
char a[1005];
char b[1005];
int minn(int a,int b,int c)
{
    int maxx=aa;
    if(a<maxx)
        maxx=a;
    if(b<maxx)
        maxx=b;
    if(c<maxx)
        maxx=c;
    return maxx;
}
int main()
{
    int n1,n2;
    while(scanf("%d",&n1)!=EOF)
    {
        scanf("%s",a);
        //for(int i=0;i<n1;i++)
        //scanf("%c",&a[i]);
        scanf("%d",&n2);
        scanf("%s",b);
        //for(int i=0;i<n2;i++)
        //scanf("%c",&b[i]);
        int n=max(n1,n2);
        dp[0][0]=0;
        for(int i=1; i<=n; i++)
        {
            dp[0][i]=i;
            dp[i][0]=i;
        }
        for(int i=1; i<=n1; i++)
        {
            for(int j=1; j<=n2; j++)
            {
                if(a[i-1]==b[j-1])
                    dp[i][j]=minn(dp[i-1][j-1],dp[i-1][j]+1,dp[i][j-1]+1);
                else
                    dp[i][j]=minn(dp[i-1][j-1],dp[i-1][j],dp[i][j-1])+1;
            }
        }
        printf("%d\n",dp[n1][n2]);
    }
    return 0;
}
/*
10 AGTCTGACGC
11 AGTAAGTAGGC
*/


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值