poj 2356 Find a multiple 鸽巢原理

Find a multiple

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 9054

 

Accepted: 3883

 

Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source

Ural Collegiate Programming Contest 1999

 算法分析:

题意:

输入n,给你n个数,从中找到 m个连续的数(坑人把), 1<=m<=n,使得这m个数的和是n的倍数;如果找不到输出0

实现

我们先用一个sum数组,存取数的连续和。

如果sum[i]能否整除n,如果能则输出下标,然后直接从第一个数开始依次输出即可。

关键:如果不存在上面的那种情况

因为sum[i]%n一定是属于【1~n-1】的,而sum总共有n个,根据鸽巢定理

把多于n个的物体放到n个抽屉里,则至少有一个抽屉里有2个或2个以上的物体。

所以n sumi%n中,至少有两个是一样的;(此题一定有解,不存在输出0的情况)

如果我们找到,则说明sum[i]%n==sum[j]%n, i<j;则ij之间的数就是答案

代码实现:

#include<cstdio>  
#include<cstring>  
#include<cstdlib>  
#include<cctype>  
#include<cmath>  
#include<iostream>  
#include<sstream>  
#include<iterator>  
#include<algorithm>  
#include<string>  
#include<vector>  
#include<set>  
#include<map>  
#include<stack>  
#include<deque>  
#include<queue>
using namespace std;
typedef long long ll;
int n,sum[10005],mod[10005];
int main()
{	
	while(scanf("%d",&n)!=EOF)
	{
		sum[0]=0;
		memset(mod,0,sizeof(mod));
	
		for(int i=1;i<=n;i++)
		{
			   int x;
			scanf("%d",&x);
			sum[i]=sum[i-1]+x;
		
		}
		for(int i=1;i<=n;i++)
		{
			if(sum[i]%n==0)
			{
			
			cout<<i<<endl;
			  for(int j=1;j<=i;j++)
			  	printf("%d\n",sum[j]-sum[j-1]);
			  	break;
			  
			}
			if(mod[sum[i]%n]!=0)
			{
				int j=mod[sum[i]%n]+1;
	           cout<<i-j+1<<endl;
			 
	           for(;j<=i;j++)
	         	printf("%d\n",sum[j]-sum[j-1]);
			    break;
			}
			mod[sum[i]%n]=i;
		}
	    
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值