POJ 3311 Hie with the Pie 状态压缩DP TSP问题(两种方法)

Hie with the Pie

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 9728

 

Accepted: 5250

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

East Central North America 2006

算法分析:

题意:

给你一个有n+1(1<=n<=10)个点的有向完全图,用矩阵的形式给出任意两个不同点之间的距离。(其中从i到j的距离不一定等于从j到i的距离)现在要你求出从0号点出发,走过1到n号点至少一次,然后再回到0号点所花的最小时间。

 

输入:包含多组实例。每个实例第一个为n,然后是n+1行矩阵,每行矩阵有n+1个数字,第i行第j个数字表示从i-1到j-1号点的距离。当输入n=0时表示输入结束。

 

输出:最小距离。

分析:

本题和经典TSP旅行商问题类似,但是TSP要求每个节点仅走过1次,本题要求每个节点至少走过一次。

但是模板还是一样套。

思路:s表示已经经过的城市的集合,v表示现在正处在的城市。定义dp[s][v]为从v出发访问所有剩余的城市,再返回起点所需要的最短的路径。mp[i][j] 表示 i 到 j 的最短路。

V为所有顶点的集合。初始化dp[V][0] = 0

状态转移方程:

dp[s][v]=min(dp[s|{u}][u] +mp[u][v]) (u不属于s)

两个方法实现:记忆化搜索和递推的状态压缩DP

代码实现:

记忆化搜索:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define M 19
#define INF 0x3f3f3f3f
int n;
int mp[M][M];
int dp[1<<11][M];
void floyd()
{
    for(int k = 0;k < n;k++)
    {
        for(int i = 0;i < n;i++)
        {
            for(int j = 0;j < n;j++)
                mp[i][j] = min(mp[i][j],mp[i][k]+mp[k][j]);
        }
    }
}
int slove(int s,int v) //记忆化搜索
{
    if(dp[s][v] >= 0) return dp[s][v]; //已经有结果
    if(s == (1<<n)-1 && v == 0) return dp[s][v] = 0; //访问完所有城市
    int ret = INF;
    for(int u = 0;u < n;u++)//从u到v
    {
        if(!((s >> u) & 1)) //判断是否访问过,如果u这一位是0,即没有访问过
        ret = min(ret,slove(s|(1<<u),u)+mp[v][u]);//状态转移
    }
    return dp[s][v] = ret; //记录结果
}
int main()
{
    while(scanf("%d",&n) == 1 && n)
    {
        n++;
        for(int i = 0;i < n;i++) fill(mp[i],mp[i]+n,INF);
        for(int i = 0;i < n;i++)
        {
            for(int j = 0;j < n;j++)
                scanf("%d",&mp[i][j]);
        }
        floyd();
        memset(dp,-1,sizeof(dp));
        printf("%d\n",slove(0,0));
    }
    return 0;
}

递推:

#include<cstdio>
#include<iostream>
using namespace std;
int n,INF=1e9;
int dp[1<<11][19],mp[19][19];
void floyd()
{
    for(int k = 0;k < n;k++)
    {
        for(int i = 0;i < n;i++)
        {
            for(int j = 0;j < n;j++)
                mp[i][j] = min(mp[i][j],mp[i][k]+mp[k][j]);
        }
    }
}
int main()             
{
	while(scanf("%d",&n)!=EOF&&n)
	{
		n++;
		for(int i = 0;i < n;i++) 
		fill(mp[i],mp[i]+n,INF);
		
		for(int i=0;i<n;i++)
		 for(int j=0;j<n;j++)
		    cin>>mp[i][j];
	
	for(int S=0;S<(1<<n);S++)
	{
	fill(dp[S],dp[S]+n,INF);
	}
	floyd();
	dp[(1<<n)-1][0]=0;
	for(int S=(1<<n)-2;S>=0;S--){
		for(int v=0;v<n;v++){
			for(int u=0;u<n;u++){
				if(!(S>>u&1)){
					dp[S][v]=min(dp[S][v],dp[S|1<<u][u]+mp[v][u]);
				}
			}
		}
	}
	cout<<dp[0][0]<<endl;
	}
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值