1037 Magic Coupon (25) [贪⼼算法]

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N**C, followed by a line with N**C coupon integers. Then the next line contains the number of products N**P, followed by a line with N**P product values. Here 1≤N**C,N**P≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3结尾无空行

Sample Output:

43



结尾无空行

Code:

/*
题⽬⼤意:给出两个数字序列,从这两个序列中分别选取相同数量的元素进⾏⼀对⼀相乘,问能得到
的乘积之和最⼤为多少
分析:把这两个序列都从⼩到⼤排序,将前⾯都是负数的数相乘求和,然后将后⾯都是正数的数相乘
求和
*/
#include <bits/stdc++.h>
using namespace std;
vector<int> v1, v2;
int nc, np;
int main()
{
    cin >> nc;
    for (int i = 0; i < nc; i++)
    {
        int temp;
        cin >> temp;
        v1.push_back(temp);
    }
    cin >> np;
    for (int i = 0; i < np; i++)
    {
        int temp;
        cin >> temp;
        v2.push_back(temp);
    }
    sort(v1.begin(), v1.end());
    sort(v2.begin(), v2.end());
    int ans = 0;
    int p = 0, q = 0;
    int len1 = v1.size(), len2 = v2.size();
    while (p < len1 && q < len2 && v1[p] < 0 && v2[q] < 0)
    {
        ans += v1[p] * v2[q];
        p++;
        q++;
    }
    p = len1 - 1;
    q = len2 - 1;
    while (p >= 0 && p >= 0 && v1[p] > 0 && v2[q] > 0)
    {
        ans += v1[p] * v2[q];
        p--;
        q--;
    }
    cout << ans << endl;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值