1044 Shopping in Mars (25 分)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯D**N (D**i≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of ij such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of ij such that Di + … + Dj >M with (Di + … + DjM) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13结尾无空行

Sample Output 1:

1-5
4-6
7-8
11-11结尾无空行

Sample Input 2:

5 13
2 4 5 7 9结尾无空行

Sample Output 2:

2-4
4-5结尾无空行

Code:

/*
前缀和加二分
对于每一个前缀和i,对后面的区间寻找一个点和i的差最接近m的解
*/
#include<bits/stdc++.h>

using namespace std;
vector<int> sum;
vector<pair<int, int>> res;
int tempsum;
int tempright;
int n, m;
int mincost = 1e9;

void binarySearch(int start)
{
    int left = start, right = n;
    int mid;
    while (left < right)
    {
        mid = left + right >> 1;
        if (sum[mid] - sum[start - 1] >= m)
            right = mid;
        else
            left = mid + 1;
    }
    tempsum = sum[left] - sum[start - 1];
    tempright = right;
}

int main()
{

    cin >> n >> m;
    sum.resize(n + 1);
    for (int i = 1; i <= n; i++)
    {
        cin >> sum[i];
        sum[i] += sum[i - 1];
    }
    for (int i = 1; i <= n; i++)
    {
        binarySearch(i);
        if (tempsum > mincost)
            continue;
        //二分查找可能没有结果
        if (tempsum >= m)
        {
            if (tempsum < mincost)
            {
                mincost = tempsum;
                res.clear();
            }
            res.push_back({i, tempright});
        }
    }
    for (int i = 0; i < res.size(); i++)
        printf("%d-%d\n", res[i].first, res[i].second);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值