UVA 864 Steps

yiyi:开始和结束的步数都是1   而且每一步只能比前一步大1,小1, 或者和上一步相等(我就不懂哪里体现出这个了)    所以从头和尾一起增加步数   用flags变量来控制  


题目:

Description

Download as PDF

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers:  0$ \le$x$ \le$y < 231 . For each test case, print a line giving the minimum number of steps to get from  x  to  y .

Sample Input 

3
45 48
45 49
45 50

Sample Output 

3
3
4

答案:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

int main () {
	int n, a, b;
	int minus, count, step;
	scanf("%d", &n);
	while (n--) {
		scanf("%d%d", &a, &b);
		bool flags = false;
		minus = b - a;
		count = 0;
		step = 1;
		while (minus > 0) {
			minus = minus - step;
			count++;
			if (flags)
				step++;
			flags = !flags;
		}
		printf("%d\n", count);
	}

		return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值