configure: error: no termcap library found--树莓派

树莓派安装gdb:
树莓派系统环境:4.9.80-v+
注:这边的操作是直接在树莓派上进行的,没有使用交叉编译

首先去官方网站下载gdb的源码包,
wget http://ftp.gnu.org/gnu/gdb/
我下载的gdb-7.8.tar.gz版本的源码包,解压开来,进入到源码包的根目录下。对于一个源码包,拿到手里首先要阅读的就是README,然后看一下INSTALL文件,这个文件里编译源码包的步骤。

基本上所有的源码包都是三步,configure,make,make install。

但是,在make的时候会出现如下错误:

configure: error: no termcap library found

这个时候的解决办法是
从官方下载termcap源码包
wget https://fossies.org/linux/misc/old/termcap-1.3.1.tar.gz/

之后同样三步,configure,make,make install

然后,再对gdb源码进行 make 和make install

阅读更多
换一批

没有更多推荐了,返回首页