J - Largest prime factor

J - Largest prime factor
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Everybody knows any number can be combined by the prime number. 
Now, your task is telling me what position of the largest prime factor. 
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc. 
Specially, LPF(1) = 0. 
 

Input

Each line will contain one integer n(0 < n < 1000000). 
 

Output

Output the LPF(n). 
 

Sample Input

     
     
1 2 3 4 5
 

Sample Output

     
     
0 1 2 1 3
最小生成元的查找。注意用到了判断素数的方法,快速打出素数表的方法。
#include<stdio.h>
#include<math.h>
#include<string.h>
int biaoji[1000010];
int cun[1000010];

bool f(int n)
{
	if(n<=1)
	return false;
	 int sqr=sqrt(1.0*n);
	for(int i=2;i<=sqr;i++)
	{
		if(n%i==0)
		{
			return false;
		}
	}
	return true;
}
int main()
{
	int n;
	memset(biaoji,0,sizeof(biaoji));
	memset(cun,0,sizeof(cun));
    int k=1;
		cun[1]=0;
		biaoji[0]=1;
		     for(int i=2;i<1000001;i++)
		     {
		     	if(biaoji[i]==0&&f(i)==true)
		     	{ 
		     			cun[i]=k;
		                biaoji[i]=1; 
		     			for(int j=i;j<1000001;j+=i)
		     	    	{
						 biaoji[j]=1;
		     	    	 cun[j]=k;
						 }
		     	    	k++;
				 }
				 else
				 if(f(i)==false)
				 {
				 	biaoji[i]=1;
				 }
				 
				 
		    }
		    while(scanf("%d",&n)!=EOF&&n!=0)
	{
		if(n==1)
		printf("0\n");
		else
		{
		
		    printf("%d\n",cun[n]);
		
		}
		    
		}
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值