mplayer安装故障Error:The GUI requires libavcodec with PNG support (needs zlib).

Check "config.log" if you do not understand why it failed.
[root@localhost MPlayer-1.1.1]# yum install zlib
已加载插件:langpacks, refresh-packagekit
软件包 zlib-1.2.8-3.fc20.x86_64 已安装并且是最新版本
无须任何处理
[root@localhost MPlayer-1.1.1]# 

求破


已搞定。
Error: The GUI requires libavcodec with PNG support (needs zlib).
于是安装zlib-devel,却发现:
软件包 zlib-1.2.8-3.fc20.x86_64 已安装并且是最新版本
无须任何处理
度娘表示已经尽力,无可奈何,只好找谷哥:
搜到这篇笔记 http://hgf2067.blog.163.com/blog/static/116291260200961694152742/ 就安装libXv-devel:
已安装:
libXv-devel.x86_64 0:1.0.9-2.fc20 
configure,结果needs zlib解决,又出现新的问题:
Error: The GUI requires the X11 extension XShape (which was not found).
谷哥给我看这个帖子 http://www.murga-linux.com/puppy/viewtopic.php?t=81244&sid=959474cf2169095a6ea49ab3d22d5ad9 ,于是在configure里加入 --enable-xshape:
Config files successfully generated by ./configure --prefix=/usr/local………………
于是我就make去了,bye

阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭