[九度OnlineJudge][剑指Offer]题目1512:用两个栈实现队列

题目描述:

用两个栈来实现一个队列,完成队列的Push和Pop操作。
队列中的元素为int类型。

输入:

每个输入文件包含一个测试样例。
对于每个测试样例,第一行输入一个n(1<=n<=100000),代表队列操作的个数。
接下来的n行,每行输入一个队列操作:
1. PUSH X 向队列中push一个整数x(x>=0)
2. POP 从队列中pop一个数。

输出:

对应每个测试案例,打印所有pop操作中从队列pop中的数字。如果执行pop操作时,队列为空,则打印-1。

样例输入:
3
PUSH 10
POP
POP
样例输出:
10

-1

#include <iostream>
#include <stack>
#include <string>
#include <cstdio>
using namespace std;
 
int main()
{
    //freopen("input.txt","r",stdin);
    int n;
    cin>>n;
    string operation;
    int data;
    stack<int> stack1;
    stack<int> stack2;
    for(int i=0;i<n;i++)
    {
        cin>>operation;
        if(operation=="PUSH")
        {
            cin>>data;
            stack1.push(data);
        }
        else
        {
            if(stack2.empty())
            {
                while(!stack1.empty())
                {
                    stack2.push(stack1.top());
                    stack1.pop();
                }
                if(stack2.empty())
                    cout<<-1<<endl;
                else
                {
                    cout<<stack2.top()<<endl;
                    stack2.pop();
                }
            }
            else
            {
                cout<<stack2.top()<<endl;
                stack2.pop();
            }
        }
    }
    return 0;
}
 
 
/**************************************************************
    Problem: 1512
    User: fuestck
    Language: C++
    Result: Accepted
    Time:580 ms
    Memory:1656 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值