Symmetric Order
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 9787 | Accepted: 6033 |
Description
In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.
Input
The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.
Output
For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.
Sample Input
7 Bo Pat Jean Kevin Claude William Marybeth 6 Jim Ben Zoe Joey Frederick Annabelle 5 John Bill Fran Stan Cece 0
Sample Output
SET 1 Bo Jean Claude Marybeth William Kevin Pat SET 2 Jim Zoe Frederick Annabelle Joey Ben SET 3 John Fran Cece Stan Bill
Source
先给一个数字N,之后N行得到N个字符串,要求,先让奇数行输出,之后再从后,让偶数行输出。
直接模拟,奇数行用一个单循环输出到最大,之后偶数行从N - 1 - N % 2行,向0行递减输出。
注意点:
1)
字符串数组从0开始,
N为奇数,则偶数起始行为N-2;
N为偶数,则偶数起始行为N-1;
即 偶数起始行为N-1-N%2。
代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>
char str[100][30];
int main(void){
int casenum, ii;
int N;
int i;
for (ii = 1; 1; ii++){
memset(str, 0, sizeof(str));
scanf("%d", &N);
if (!N){
break;
}
getchar();
for (i = 0; i < N ; i ++){
scanf("%s", str[i]);
}
printf("SET %d\n", ii);
for (i = 0; i < N; i += 2){
printf("%s\n", str[i]);
}
for (i = N - 1 - N % 2; i >= 0 ; i -= 2){
printf("%s\n", str[i]);
}
}
return 0;
}