HDOJ 2058 The sum problem (数学题)

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19042    Accepted Submission(s): 5650


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

Sample Input
  
  
20 10 50 30 0 0
 

Sample Output
  
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
题目链接: HDOJ 2058 The sum problem (数学题)

题意  找一个连续数列使其和为 M 输出数列的首相和尾相(格式)(N没什么用) 

思路:数据较大  暴力查找超时  根据 连续数列和的计算公式 (首相为s,尾相为e,相数为num)  M=(s+e)*num/2;

   由 num=e-s+1;  可得 s=(2*M/num+1-num)/2;  e=s+num-1; 

所以 通过对num(数列个数循环),可得 首相 s,尾相 e ,最后判断s 和 e 是否满足 M=(s+e)*num/2; 

已AC代码:

#include<cstdio>
#include<cmath>
int main()
{
	int n,m,s,e,num;
	while(scanf("%d%d",&n,&m),n,m)
	{
		for(num=pow(2.0*m,0.5);num>=1;--num) //num为相数 最多为 pow(2.0*m,0.5)
		{
			s=(2*m/num+1-num)/2; //首相 (其最小为 1 ) 
			e=s+num-1; //尾相 
			if((s+e)*num/2==m) //计算过程有取整,要判断是否满足 
				printf("[%d,%d]\n",s,e);
		}
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值