HDOJ 1556 Color the ball(树状数组 & 线段树)

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13560    Accepted Submission(s): 6809


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
  
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
  
  
1 1 1 3 2 1
 

Author
8600
题目链接: HDOJ 1556 Color the ball(树状数组 & 线段树)

已AC代码一:(树状数组)

#include<cstdio>
#include<cstring>
#define M 100010
int n,tree[M];
int lowbit(int i)
{
	return i & (-i);
}
void updata(int pos,int val)
{
	while(pos>0)//更新 1~pos的值 
	{
		tree[pos]+=val;
		pos-=lowbit(pos);
	}
}
int Query(int pos)
{
	int sum=0;
	while(pos<=n)
	{
		sum+=tree[pos];
		pos+=lowbit(pos);
	}
	return sum;
}

int main()
{
	int i,a,b;
	while(scanf("%d",&n),n)
	{
		memset(tree,0,sizeof(tree));
		for(i=1;i<=n;++i)
		{
			scanf("%d%d",&a,&b);
			updata(b,1);//从 1 到 b 加一 
			updata(a-1,-1);//从1 到 a-1 减一 
		}
		printf("%d",Query(1));
		for(i=2;i<=n;++i)
		{
			printf(" %d",Query(i));
		}
		printf("\n");
	}
	return 0;
}
已AC代码二:(线段树)
#include<cstdio>
#include<cstring>
#define M 100010

struct TREE{
	int left,right,sum;
}tree[M*4];
int n,sum,num[M];

void build(int l,int r,int root)//建树 
{
	tree[root].left=l;
	tree[root].right=r;
	tree[root].sum=0;//初始为 0 
	if(l==r)
		return ;
	int mid=(tree[root].left+tree[root].right)>>1;
	build(l,mid,root<<1);
	build(mid+1,r,root<<1|1);
}
void updata(int l,int r,int root)//更新 
{
	if(tree[root].left==l && tree[root].right==r)
	{
		tree[root].sum++;//区间都加一 
		return ;
	}
	if(tree[root].left==tree[root].right)//单点返回 
		return ;
	int mid=(tree[root].left+tree[root].right)>>1;
	if(r<=mid)
		updata(l,r,root<<1);
	else if(l>mid)
		updata(l,r,root<<1|1);
	else
	{
		updata(l,mid,root<<1);//注意 
		updata(mid+1,r,root<<1|1);
	}
}
void Query(int pos,int root)//查询 
{
	sum+=tree[root].sum;
	if(tree[root].left==tree[root].right)
		return ;
	int mid=(tree[root].left+tree[root].right)>>1;
	if(pos<=mid)
		Query(pos,root<<1);
	else
		Query(pos,root<<1|1);
}
int main()
{
	int i,a,b;
	while(scanf("%d",&n),n)
	{
		build(1,n,1);
		for(i=1;i<=n;++i)
		{
			scanf("%d%d",&a,&b);
			updata(a,b,1);//从 a 到 b 加一 
		}
		for(i=1;i<=n;++i)
		{
			if(i!=1)
				printf(" ");
			sum=0;
			Query(i,1);
			printf("%d",sum);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值