HDU2844:Coins

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4

多重背包
二进制优化:把一件物品的数量s,分为1,2,4,8,16,32,。。。,2^k,s-(2^(k+1)-1),进行01背包
                     其中k使得2^(k+1)>s-(2^(k+1)-1)
原理:前面k+1组数可以组成0~2^(k+1)-1范围内的任意一个数,最后一项与之前的若干项又可以组成 s-(2^(k+1)-1)~s范围内的任意一个数,
          而2^(k+1)>s-(2^(k+1)-1)使得覆盖范围为0~s
进一步优化:物品数量是s,体积m,总体积v,按照s*m与v的关系,转化成无限背包与上诉01背包

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#define max2(a,b) ((a)>(b)?(a):(b))
using namespace std;
typedef long long ll;
typedef pair<int,int> pii;
int dp[100010];
void completepack(int v,int a){
   for(int i=a;i<=v;i++)
    dp[i]=max2(dp[i],dp[i-a]+a);
}
void zeropack(int v,int a){
for(int i=v;i>=a;i--)
    dp[i]=max2(dp[i],dp[i-a]+a);
}
void mulpack(int v,int a,int c){
if(c*a>=v){
    completepack(v,a);
    return;
}
else{
    int k=1;
    int w=c;
    while(k<=w){
        zeropack(v,k*a);
        w-=k;
        k*=2;
    }
    zeropack(v,w*a);
}
}
int main(){
int n,m;
while(scanf("%d%d",&n,&m)&&(n||m)){
    int a[110];
    int c[110];
    for(int i=1;i<=n;i++)scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)scanf("%d",&c[i]);
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=n;i++)
        mulpack(m,a[i],c[i]);
int num=0;
for(int i=1;i<=m;i++)if(dp[i]==i)num++;
printf("%d\n",num);
}
return 0;}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值