POJ 2253 Frogger最短路变形

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 54887 Accepted: 17298

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意是一只青蛙要从第一块石头跳到第二块石头,但水很脏所以不是游过去而是通过跳到不同的石头最后跳至终点。

可以想像,有很多种不同的路径。

最后需要求出这所有的路径中最长的跳跃距离的最小值。

好像有点拗口?

就是每一条路都会有最长的一个中间的跳跃距离(两块石头之间的距离),那我们需要找一条路,使得这条路中的最长跳跃距离尽可能的小,即为题目要求的Frog Distance。

即青蛙只需要最长的跳跃距离到达这个距离,就可以从第一块石头跳到第二块石头上。

这道题的解法最短路的变形

这里使用dijkstra、改变一下松弛条件。

如果与这个结点和与之相连的结点的边的最大值比还没求出结果的结点要小的话

就进行松弛。

//#include <bits/stdc++.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <stdio.h>
#include <string.h>
#include <vector>
#include <cmath>
const int inf = 1e6;
const int N = 1000;
int n;
using namespace std;
typedef pair<int,int> pii;
pii maze[N];//存储每个点的坐标
double maxdis[N];//maxdis[i]表示从起点到i点路上的最大跳跃距离(即maxdis[1]即为答案)
double dis(int i,int j)
{
    return sqrt(pow((maze[i].first-maze[j].first), 2)+pow(maze[i].second-maze[j].second,2));
}
bool book[N];
void dijkstra()
{
    for(int i = 1 ; i < n; i++)
        maxdis[i] = dis(0,i);
    book[0] = 1;
    for(int i = 1; i < n; i++)
    {
        int v = -1;
        double mmin = inf;
        for(int j = 0; j < n; j++)
        {
            if(maxdis[j] < mmin && book[j] == 0){
                v = j;
                mmin = maxdis[j];
            }
        }
        book[v] = 1;
        for(int j = 0; j < n; j++)
        {
            if(book[j] == 0 && max(maxdis[v],dis(v,j)) < maxdis[j]){
                maxdis[j] = max(maxdis[v],dis(v,j));
            }
        }
    }
}
void init()
{
    memset(book, 0, sizeof(book));
    memset(maxdis,0,sizeof(maxdis));
    memset(maze,0,sizeof(maze));
}
int main()
{
    //ios::sync_with_stdio(false);
    int cas = 1;
    while(~scanf("%d",&n),n)
    {
        init();
        for(int i = 0; i < n; i++)
            scanf("%d%d",&maze[i].first, &maze[i].second);
        dijkstra();
        printf("Scenario #%d\n",cas++);
        printf("Frog Distance = %.3f\n\n",maxdis[1]);
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值